0

my upload speed is much to slow. I have 2 networkcards RTL8111/8168/8411. Download speed is ok but upload speed is much to slow, about 150 mbps. i installed Windows 7 on the system en there was no problem at all! i went back to Ubuntu 15.10 server edition. I set the cards on full duplex 1000mbit, Ipv6 is not running. I have 500/500 fiber glass. Please help!


ethtool:

Settings for enp1s0f0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Half 1000baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

$ iptables -v -x -n -L
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

 iptables -t nat -v -x -n -L
Chain PREROUTING (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

Chain POSTROUTING (policy ACCEPT 0 packets, 0 bytes)
    pkts      bytes target     prot opt in     out     source               destination

$ ethtool -i enp1s0f0
driver: r8169
version: 2.3LK-NAPI
firmware-version:
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

I have the accurate drivers for the network cards.

  • Check Your MTU settings in Your adapter, also please provde output for these commands: ethtool eth0, sudo iptables -v -x -n -L and sudo iptables -t nat -v -x -n -L – Eska Apr 6 '16 at 17:14
  • Please check if You have accurate drivers for Your network cards, according to this post there were issues with the speed caused by the drivers. – Eska Apr 6 '16 at 17:22
  • Whats Your MTU value? ip link list – Eska Apr 6 '16 at 21:33
  • ip link list 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: enp1s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000 link/ether 00:22:ab:80:17:de brd ff:ff:ff:ff:ff:ff 3: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000 link/ether 00:22:ab:80:19:1e brd ff:ff:ff:ff:ff:ff – hanssol Apr 7 '16 at 6:36
0

Install another driver for this Ethernet card. Run

sudo apt-get install r8168-dkms

and reboot.

  • It's not working for me, still poor upload speed – hanssol Apr 7 '16 at 11:27
  • how do you measure upload speed? – Pilot6 Apr 7 '16 at 12:36
  • speedtest-cli Retrieving speedtest.net configuration... Retrieving speedtest.net server list... Testing from XS4ALL Internet BV (************)... Selecting best server based on latency... Hosted by INTERACTIVE 3D B.V. (Rotterdam) [32.49 km]: 9.211 ms Testing download speed........................................ Download: 487.32 Mbit/s Testing upload speed.................................................. Upload: 183.36 Mbit/s – hanssol Apr 7 '16 at 12:47
  • Whit windows installed its up to 580 Mbit/s – hanssol Apr 7 '16 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.