0

Newbie here. Been an IAR baremetal embedded guy for years. Ubuntu transition is painful.

I've installed Ubuntu 14.04. I've installed SDK and Qt Creator and I'm trying to build...anything. Nothing works.

Gone through tutorials online, nothing looks quite like what I have.

when I select "Create a New Project" my Ubuntu options are :

QML App with Simple UI (cmake) QML App with Simple UI (qmlproject) QML App with Simple UI (qmake) QML App with C__ plugin (qmake) QML App with C++ plugin (cmake) ....

tutorials always show: "App with Simple UI" ... nope. I dont have that option

So I choose ..anything, Ive tried them all, and they require some Ubuntu component of which I guess I dont have, since in the Main.qml there is always a red line under

import Ubuntu.Components 1.3

Depending on what I choose to make, it's 1.1, or 1.3 but I need those Components to build anything I guess??

Any help will be much appreciated.

Any guide to any tutorial that will work for me is also very welcome

Thanks for your help, Dubs

0

I ended up re-installing Qt5 by downloading an installer file. I had to change that file into an executable and then I ran it and Qt re-installed and it worked.

All the examples disappeared after I closed it the first time, so googled that problem and someone came up with some command lines to do to get the examples back and those worked.

So I would advise you to re-install Qt from their website using an installer. I suspect that you, like I, had Qt installed incorrectly or incompletely.

1
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster May 7 '16 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.