0

I have a Raspberry Pi 3 with Raspbian installed on it.

If I insert a SD card with Ubuntu Mate (ARM) 14.04 on it, I can't even get to the colorful boot screen (boot loader?). I've tried various SD cards with the same results. I tried those same SD cards on a Raspberry Pi 2 model B and they work fine, so I've determined it's not the installation media, it's something with the software.

How can I install Ubuntu Mate (ARM) on a raspberry pi 3?

Solution

Based on the accepted answer I performed the following on Mac OS X 10.11.3 (El Capitan):

  • Downloaded Ubuntu Mate from the Canadian mirror (I'm in NY)
  • Decompressed ubuntu-mate-15.10.3-desktop-armhf-raspberry-pi-2.xz file by double clicking it
  • Opened terminal (CMD+space, "terminal", enter)
  • $ diskutil list my SD was listed as /dev/disk1
  • $ diskutil unmountDisk /dev/disk1
  • $ sudo dd if=Downloads/ubuntu-mate-15.10.3-desktop-armhf-raspberry-pi-2.img of=/dev/rdisk1 bs=1024m

I modified a line in config.txt that is specific for my waveshare screen to display, unmounted, and took out the SD card to plug it in the rpi3.

1 Answer 1

3

The Pi 3 uses a completely different SOC (BCM 2837). The build your are running only supports the BCM2835 and BCM2836.

There is a new build that adds support for the Pi 3's SOC. Download it here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.