I have booted up an Ubuntu live-CD but I can't seem to install the prop. drivers (the only drivers for my ASUS AMD R9 390 that are stable enough to last more than 20 minutes without crashing).

I click on both the prop. options and it goes to install them but all of a sudden the dialogue resets.

I have done this without issue before, but I needed to wipe my SSD for a work reason.

2 Answers 2


First you have to install Ubuntu and after having finished it, boot into the installed system. Now you can install the AMD drivers from the Additional Drivers tab. Alternatively you can install the proprietary drivers by using the terminal, open a terminal and execute the following commands:

sudo apt-get update  
sudo apt-get install fglrx  
sudo reboot  

Update addressing your comment that the open source drivers prevent you from installing:

When booting from the installation media, select Try Ubuntu without installing, press the E key and add radeon.modeset=0 at the end of the linux line ... press F10 to boot. Install Ubuntu.

Reboot - select the Ubuntu menu entry, press the E key and add radeon.modeset=0 at the end of the linux line ... press F10 to boot. Install the proprietary AMD drivers as described before.

Important : Put a Space between the last character of the linux line and radeon.modeset=0.
After the proprietary AMD drivers are installed, adding the boot parameter is not necessary.

Note: fglrx will not be available in the repositories of Ubuntu 16.04 LTS, which will be released in a few days, so when you want to upgrade you may want to consider not to install these drivers. Ubuntu 16.04 most probably will offer the new amdgpu (replacement) drivers in the repositories.

As a workaround you can can deactivate the radeon open source drivers by adding the parameter to the /etc/default/grub file, so that the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line reads -> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0". Save these changes you have made and update GRUB afterwards - open a terminal and execute: sudo update-grub.

  • I have done that. But I lack the dependencies. I try to install the dependency and than it seems that it too lacks dependencies. I'll try this again. However, I can not install Ubuntu because the open drivers crash my PC before installation is finished. I have tried using the integrated graphics in my i3 6100 but nothing happens.
    – Luke889
    Commented Apr 6, 2016 at 8:01
  • Thankyou. So I've done that. Worked fine. I installed the drivers and started downloading apps. After a while my terminal dissapeared. So I rebooted and now if I log in all I see is the desktop wallpaper. I can't even call the terminal with hotkeys. I always have issues with Linux on laptops but never really had an issue with it on the desktop until the last three weeks where it feels like I've been dealing with an issue every day, I've no idea what has changed.
    – Luke889
    Commented Apr 6, 2016 at 17:09
  • @Luke889 : You're welcome - AMD drivers support in comparison to NVIDIA is known to be "not one of the best", to say it as positive as possible. I suggest that you make a clean new installation of Ubuntu 16.04 LTS after the final release on April, 21st. It ships with kernel 4.4 which has much improved hardware support. If you don't want to wait so long, the second beta version already is available : releases.ubuntu.com/16.04 ! :)
    – cl-netbox
    Commented Apr 6, 2016 at 17:27

Perhaps it is a better option to wait for 16.04 LTS - Kernel 4.4/4.5 bring much better support for highend-gpus to you with the new amdgpu-driver . So there will be no need for fglrx on 16.04.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .