0

I recently bought myself a new Lenovo Thinkpad E460 (i5 Version) and installed Ubuntu 15.10 on it.

Now my Problem is that if I try to suspend my Notebook, one of three things will happen:

  1. it goes into suspend mode correctly (power light pusling)
  2. screen turns off, but the power light doesn't pulse, the fan turns up and i can only get it out by holding the power button down
  3. the screen doesn't turn off (when using $ pm-suspend) and the notebook freezes

Cosing the lid, hitting suspend at top right corner, or $ sudo pm-suspend doesnt make a difference here (except $ sudo pm-suspend freezing the notebook with screen still on)

As I said it's a Lenovo Thinkpad E460 (i5-6200u, AMD Radeon R7-M360) and i have Ubuntu 15.10. installed, updated and upgraded. My BIOS version is 1.12 (I don't know how to update it and would rather not do it) Im not an advanced Ubuntu user yet, so I haven't tried much myself yet.

The solutions I found so far were:

  1. Disabling USB 3.0 in BIOS -> My BIOS doesn't offer this option
  2. Updating the BIOS -> I don't know how to do this correctly

As this is a rather nasty bug, I hope you can help me solve it.

EDIT

I found out the bug with suspending the notebook only exists when NOT connected to power. But then it's quite reliable that the Notebook will freeze. I also tried installing proprietary graphics drivers, which didn't help

Greetings.

1

I had the same problem running Ubuntu 16.04 on the same laptop (both with and without the power connected). In desperation I updated the kernel from 4.4 to 4.5.3 (see here and here for instructions) and the problem seems to have gone - both for closing the laptop lid and selecting 'suspend' from the menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.