1

Background

I'm planning on doing a lot of R&D on different ubuntu services and decided that I want to run most of it through KVM. But because I want to create a few different servers and try different flavours I thought I would give caching a go (I have installed various ubuntu servers flavours over the last few days and thought that before I go massively deploying and later updating multiple servers, I would get this caching under my belt).

I decided on squid-deb-proxy as it seemed to be the most recommended and least config needed and I feel the last few hours have proved that wrong. I initially followed the instructions from:

Best way to cache apt downloads on a LAN?

and when I first started hitting stumbling blocks and realised the post was 6 years old, I looked to the second option, but after realising that in that answers comment's the author of the answer also made the switch to squid-deb-proxy.

Various google and stack searches bring me back to Jorge's post/answer

Setup

I have tried this on both Server 15.10 and 16.04* as servers and ubuntu desktops 14.04, 15.10 and 16.04 as clients. All are failing miserably.

My current setup as physical devices are now 16.04 and vm's (both desktop and server) are 15.10. I did have one 14.04 physical machine at the start of the night, but that has been upgraded in the process.

*Yes, I know it's beta, but I did try 15.10 first and still have the VM here to refer to.

What I've tried

Well after trying to follow the instructions located at Best way to cache apt downloads on a LAN? I meet resistance already in the server config.

First off, did the install:

sudo apt-get install squid-deb-proxy avahi-utils

Then starting the server I'm learning that:
sudo start squid-deb-proxy
is now
sudo service squid-deb-proxy start

Moving onto the clients, it's seemed to install, no errors, neither at the command line or thru the software manager.

Learned

From the original page there is a comment that squid isn't installed, no update from the author, but I install squid, restart squid and squid-deb-proxy... no go...

Much further down the track I've done the same install but installed squid3 instead of squid with the same results.

I found that my network didn't appear correct in:

/etc/squid-deb-proxy/allowed-networks-src.acl

They've been added and re-added as exact IP addresses, to no avail.

I have touched (because it didn't exist) /var/log/squid-deb-proxy/access.log and tailed that and squid/squid3 logs, and I am getting nothing.

I have been at this for too many hours and will post now. I will update with any requests or follow-up on any ideas after some sleep.

I have searched but if anyone else has a more thorough (for idiots) guide, I'd be appreciative. The server is only a day old. I am prepared to reinstall everything from scratch if need be (it is currently 16.04beta, but that's because of drive issues with Seagate SMR drives BTRFS, but I have tried and failed on 15.10 but can reinstall that in around 600 heart beats). Any help appreciated

Guesses

I have no idea, I'm starting to think I should have installed squid3 and not squid, but nothing explicitly states that. I haven't explicitly setup squid(/3) other than the apt-install, but there were no caveats anywhere to install that first then do squid-deb-proxy...

Conflicts between squid/squid3? TBH, I have installed so many times just today alone in physical and VM's that I really have no idea. Sorry if I'm sounding confused (it's late).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.