2

Aloha - of course this could be a sublime text issue, but here goes the issue just in case someone can point me in the right direction.

I have been using Sublime 3 on Ubuntu without issue. Yesterday my computer froze up and I had to hard reboot. Sublime text was running when I had to do the hard boot. Then when computer reloaded, I could not open sublime text, the icon shows in the left sidebar as sublime text is running when I open it, and when I use "alt + tab" to rotate through open applications it is there as an icon. However the application is just not actually opening for me to use it, the GUI is just not showing. If I "alt+tab" to it, nothing.

I uninstalled and reinstalled Sublime Text 3 also, but still the same issue.

3

If an application does not work after a crash

Remove ~/.config/sublime-text-3, immediately log out and back in. I am pretty sure it will work then.

In these situations, local files can get corrupted, rather then the global ones. The fact that you reinstalled Sublime Text with no success is another indication the cause is locally.

3

In my opinion, the previous answer is a bit over the top. It's likely enough to delete the .sublime-session files in ~/.config/sublime-text-3/Local. Your configuration will stay intact, as will all installed packages and the license data (if available.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.