1

I faced a really weird issue recently in Ubuntu 14.04 LTS Here are the steps:

  1. I have a deb package called test.deb which has dependency on xorg-dev
  2. Then I tried to install this deb package by sudo apt-get install test
  3. All dependencies are installed except for xorg-dev. The error is Depends: xorg-dev but it is not going to be installed
  4. I ran this next sudo apt-get install xorg-dev
  5. xorg-dev got installed successfully

My question is apt-get should be able to install all dependencies available. Since xorg-dev is available, why it is not getting installed at first time?

  • are you sure the version you installed and the version requested by test.deb are the same? – MrVaykadji Apr 4 '16 at 22:28
  • hi, there is no version restrictions on dependencies, so could be any version. – jellyfish Apr 5 '16 at 3:06
  • Maybe it's worth trying adding a version? I'm not into packaging, but from the few debs I compiled, I seem to remember I always used a version (eg: >= 7.6) – MrVaykadji Apr 5 '16 at 14:58
  • thanks! i tried using this version xorg-dev >=1:7.7+1ubuntu8.1, but still not working. – jellyfish Apr 5 '16 at 23:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.