0

I'm running a little server at my home. As you can imagine, my IP address is dynamic. In order to get a static hostname, I'm using the services of noip.com; I've created a hostname in the website and installed and configured the client software in my server.

I've tried accessing my new no-ip hostname from the browser and it works fine, but for some reason, I can not connect with my server with SSH; whenever I try to run the command sudo su ssh -p 33 server1@noipdomain.com, I get my connection refused. I'm using the port 33 because I thought that using other port than the defaukt one, 22, might work. Of course, the port 33 has been opened and points to the private IP address. Btw, the SSH connection works fine when I try connecting from my local network with the private address of the machine.

Thanks a lot!

  • Check port connectivity with telnet <server> 33, if it worked break with Ctrl ], and quit telnet. Then add -vvv to ssh command. If telnet failed, check the same with IP. Update the question with results. – techraf Apr 4 '16 at 23:18
  • Apparently you have not managed to configure your router to forward the port. – psusi Apr 5 '16 at 0:35
0

First it may take up to 24 hours for your DNS (the "hostname" you set at no-ip) to propogate.

Second, you are running ssh wrong.

ssh user@server

no need for sudo su , if you want to connect as root you run, ssh root@server

  • You might want to add in the way to use port 33 – TheWanderer Apr 4 '16 at 22:07
  • As long as the domaine works fine in my browser, I suppose it has already propagated. Btw, with the command you suggested, I'm getting the same response: conecction refused. Please note that it is not the same response I recive when I try connecting to a host which does not exist. – pitazzo Apr 4 '16 at 22:41
0

First try with the server IP. You can run this :

ssh -p 33 username@IP

If the above command do not work then run the below command

ssh -p 33 -vvv username@IP

adding -vvv will give you the verbose from where you can see why its failing to connect.If you are not able to connect still post the output/error here

  • Thanks for answering bhordupur, but it did not work. Here is the output: OpenSSH_6.9p1 Ubuntu-2ubuntu0.1, OpenSSL 1.0.2d 9 Jul 2015 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to geomoments.no-ip.org [81.32.239.160] port 33. debug1: connect to address 81.32.239.160 port 33: Connection refused ssh: connect to host geomoments.no-ip.org port 33: Connection refused – pitazzo Apr 4 '16 at 23:15
  • According to your description, you can browse port 80/443 but not able to ssh . can u telnet? Is your firewall blocking the ssh traffic?Can you check what rules did you apply for filtering the traffic for inbound/outbound? – bhordupur Apr 5 '16 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.