2

Today I installed the Ubuntu Ubuntu 14.04.4 LTS 64 bit and I want to install the libgl1-mesa-dev:i386 packet. I execute the command:

sudo apt-get install libgl1-mesa-dev:i386

and I get the following results:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dev:i386 : Depends: libgl1-mesa-glx:i386 (= 10.1.3-0ubuntu0.6) or
                                 libgl1-mesa-glx-lts-utopic:i386 but it is not going to be installed or
                                 libgl1-mesa-glx-lts-vivid:i386 but it is not going to be installed or
                                 libgl1-mesa-glx-lts-wily:i386 but it is not going to be installed or
                                 libgl1-mesa-glx-lts-xenial:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

UPDATE

I execute the command:

dpkg -l | grep xserver-xorg-core

and I get:

ii  xserver-xorg-core-lts-wily                            2:1.17.2-1ubuntu9.1~trusty1                         amd64        Xorg X server - core server

SECOND UPDATE

sudo apt-get install libgl1-mesa-dev-lts-wily:i386

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dev-lts-wily:i386 : Depends: libgl1-mesa-glx-lts-wily:i386 (= 11.0.2-1ubuntu4~trusty1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

UPDATE 3

sudo apt-get install libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386 libgl1-mesa-dev-lts-wily:i386

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx-lts-wily:i386 : Depends: libudev1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
  • Please edit your question and add output of dpkg -l | grep xserver-xorg-core terminal command. – Pilot6 Apr 4 '16 at 18:51
  • Include libudev1:i386 and see what is needed next. – Pilot6 Apr 4 '16 at 20:15
  • always required new dependencies – Ezazel Apr 4 '16 at 20:30
0

You have wily graphical stack. The correct command should be

sudo apt-get install libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386 libgl1-mesa-dev-lts-wily:i386 libudev1:i386
  • I have posted a second update in my question with the results from your command . – Ezazel Apr 4 '16 at 19:12
  • I updated the command. – Pilot6 Apr 4 '16 at 19:17
  • I update the post with your updated command – Ezazel Apr 4 '16 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.