3

Running 16.04 beta 2. Installed i3 and am using a custom .desktop session:

[Desktop Entry]
Name=Xsession
Exec=/etc/X11/Xsession

My ~/.Xsession file starts i3.

Fonts in i3 are correct and configurable.

When using Chrome or unity-control-center, their fonts are much larger than the i3 fonts. Same with the mouse cursor, which is huge. I've looked on the other questions here about how to change font and cursor size, and nothing has worked.

Hasn't worked, as in, I have seen no visible change (these have all been suggested in other answers):

  • changing the font size using unity-tweak-tool
  • changing the cursor size using dconf-editor
  • echo "Xcursor.size:48" >> ~/.Xresources
  • gsettings set com.canonical.Unity.Interface cursor-scale-factor 2

See attached screenshot for correct-sized i3 fonts and huge chrome/unity fonts.

screen shot

  • I am also interested in figuring this out. As a suboptimal workaround, if I copy my X startup file to .xinitrc, Alt-Ctrl-F1 to switch to tty1, and run startx, I get a session where sizes are all back to normal. – rightparen Apr 24 '16 at 23:36
  • Interesting. Could it be due to lightdm doing stuff then? I wonder if trying xdm or another display manager would solve the problem. – mjibson Apr 25 '16 at 7:10
0

This appears to be caused by lightdm. I installed and configured xdm (sudo dpkg-reconfigure xdm) to be the display manager, and the fonts went back to normal and everything was working as expected after the next login.

However, lightdm handles other things that are no longer handled. The worst is that the wireless network card (on a MacBook Pro) is no longer turned on, so there's no way to connect to the internet. I'm sure this has some other solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.