1

I have ubuntu 15.10 x64 and wine x32 (playonlinux). No any sound in games (try hearthstone, C&C and etc). Try this http://oldwiki.winehq.org/WineAndPulseaudio, but zero effect. How I can fix it? Thank you for any help.

2 Answers 2

2

So I manage it by myself. Here solution:

  1. Basic advice - if you can use latest version of wine.
  2. No need in http://oldwiki.winehq.org/WineAndPulseaudio. Just use winetricks - configure - and select audio to alsa.
  3. If you use PlayOnLinux or etc you can run winetricks for separate wineprefix with command from terminal:
    WINEPREFIX=/home/link0802/.PlayOnLinux/wineprefix/RA3 winetricks
    Where:
    link0802 - your user.
    RA3 - name of you wine drive/wineprefix
    Once again select audio to alsa in winetricks

  4. If audio still doesn't work try to uncomment/set default-fragment-size-msec = 5 in /etc/pulse/daemon.conf. Run pulseaudio -k to restart pulseaudio.

  5. If problem is still here try to remove package alsa-oss. Restart pulseaudio and try again.

Additional: Sometimes you will need to run apps from wine with command line argument(for example to force game use some audio/video engine). In playonlinux you can do it like this:

  1. Open you wine drive/wineprefix settings in playonlinux. Settings - select drive your drive - Miscellaneous - open shell.
  2. Paste command in terminal
    POL_Shortcut "RA3.exe" "Red alert 3" "" "xres=1366 yres=768"
    Where:
    "RA3.exe" - exe to execute.
    "Red alert 3" - title for shortcut (second "" is desc)
    "xres=1366 yres=768" - command line arguments for exe (without "-")
  3. If you use wine without additional software just type

    wine myapp.exe -yourCMDargument

0

for normal debian repo wine

I ran: winecfg and then clicked the Audio tab, then selected Pulseaudio in all the dropdowns under the Defaults section.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.