0

I am trying to install Landscape Dedicated Server for personal use on a clean Ubuntu 14.04 server from scratch. After adding the ppa-repository and updating apt, I install the thing with apt install landscape-server-quickstart. It all goes well for a while, until:

 * Stopping Landscape standalone appserver 1                             [ OK ] 
 * Stopping Landscape standalone async-frontend 1                        [ OK ] 
 * Stopping Landscape standalone job-handler 1                           [ OK ] 
 * Stopping Landscape standalone message-server 1                        [ OK ] 
 * Stopping Landscape standalone pingserver 1                            [ OK ] 
 * Stopping Landscape standalone api 1                                   [ OK ] 
 * Stopping Landscape standalone package-upload 1                        [ OK ] 
 * Stopping Landscape standalone juju-sync 1                             [ OK ] 
WARNING: this may take some time
Site 000-default disabled.
Tuning postgresql for this machine...
 * No PostgreSQL clusters exist; see "man pg_createcluster"
cp: cannot stat '/etc/postgresql/9.3/main/postgresql.conf': No such file or directory
dpkg: error processing package landscape-server-quickstart (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...
Errors were encountered while processing:
 landscape-server-quickstart
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried it several times, but it never worked. Does anybody have a workaround?

0

The QuickStart is presumably tested against the latest point release. Try fully updating your clean LTS install first, that will get you from 14.04.0 to 14.04.3.

| improve this answer | |
0

When I ran the Landscape Server for Personal Use (the Landscape Dedicated Server), I had quite some difficulty getting the QuickStart to work.

I had much more luck with the Manual Installation than I did quick-start. I think that the Manual Installation gets everything working the way it should, while QuickStart isn't a guarantee to make it 100% work.

The instructions change from version to version, slightly, so copying the key instructions into here would be useless - please refer to the link for Manual Installation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.