0

Okay so I have a weird graphics problem on my lenovo thinkpad yoga s2. There is a strange lag between two areas of my screen. I'm sorry I couldn't take a great picture, when I tried to do a snapshot on the computer the glitch wouldn't show so I had to take a picture with my phone. So I checked what graphic card I had with lspci and here is the log:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series HECI KT (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)

I have installed the Intel Graphics Installer tool and installed all the packages but the bug is still there. I don't really know what to do and don't quite know where to look, so I'm calling to the community to help me figure this one out. Here are the images:

  • Horizontal line problem

    image 1

  • Top of the screen horizontal line

    image 2

0

So after posting my first question I will now attempt to post my first answer. So the phenomenon is called "tearing" and after looking at this link on the ArchLinux wiki

https://wiki.archlinux.org/index.php/intel_graphics#Configuration

It was mentioned that you could create a configuration file and add an option called tearfree.

So the steps are:

  1. create directory xorg.conf.d inside /etc/X11/
  2. create a file named 20-intel.conf inside /etc/X11/xorg.conf.d/ and insert these lines inside:

    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "TearFree"    "true"
    EndSection
    

Voila! No more screen tearing!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.