0

My Ubuntu 15.10 install breaks graphics when installing new nvidia drivers for my GTX 970. After the update, the hardware acceleration doesn't work as evidenced by:

Cinnamon telling me (unity is also affected)

Steam not starting with this error "X Error of failed request: BadValue (integer parameter out of range for operation)"

Overall slow UI graphics

nvidia-settings is empty https://i.imgur.com/cbUyJbm.png

I did the update via "Additional drivers" from the graphics-drivers ppa, from which the initial installation was done. Then, after it did not work, I tried a "sudo apt-get purge nvidia*" then I installed nvidia-364 from the command line, still not successful.

"lspci -vnn | grep -i VGA -A 12" says that the kernel driver is nouveau and any attempt to blacklist nouveau makes the Desktop environment not boot. Also this command list my Intel iGPU first, which is disabled in the bios and has nothing connected to it.

0

I fixed it by installing the drivers with the installer from nvidia.com.

First, I blacklisted nouveau by adding the following to /etc/modprobe.d/blacklist.conf:

blacklist vga16fb
blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

Then I ran:

sudo update-initramfs -u
sudo reboot

Go to terminal with "ctrl+alt+1". Then, I killed -9 everything from:

ps -ef | grep X

I was then able to install the drivers I downloaded from nvidia:

chmod +x NVIDIA-Linux-x86_64-361.42.run
sudo ./NVIDIA-Linux-x86_64-361.42.run

Follow the instructions on screen and reboot againl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.