1

I have been running Kubuntu 15.10 32-bit for a while, and although I love the KDE enviroment, I would like the option of having Unity. So, I did the following:

sudo apt-get update
sudo apt-get install unity

I then rebooted, and when I was at the login screen, I tried to switch from plasma to unity, but the only options were "Plasma" and "Failsafe". When i run:

sudo apt list | grep gnome

or:

sudo apt list | grep unity

I am presented with several packages saying "Unity-8-desktop", or something along those lines, so I know Unity is installed, I just can't reach it. Can anyone help me?

1

If you want Unity 7:

sudo apt install ubuntu-desktop

If you want Unity 8:

sudo apt install unity8-desktop-session-mir
  • I tried that, but it still doesn't show up in the login screen – Diogo Gomes Apr 3 '16 at 12:39
  • Run sudo dpkg-reconfigure kdm, choose lightdm when asked, and reboot your PC. – Muzaffar Apr 3 '16 at 13:47
  • I did that, but the output was the following 'dpkg-query: package 'kdm' is not installed and no information is available Use dpkg --info(= dpkg-deb --info) to examine archive files, and dpkg --contents (= dpkg-deb --contents) to list their contents. /usr/sbin/dpkg-reconfigure: kdm is not installed' – Diogo Gomes Apr 3 '16 at 16:18
  • I tried again, but i figured you must have meant 'dpkg-reconfigure sddm' and not 'dpkg-reconfigure kdm'. When I did that, it worked. However, both sddm and lightdm started fighting on the login screen. I then ran 'systemctl disable sddm', rebooted, and it's working fine now. – Diogo Gomes Apr 3 '16 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.