since the latest release of displaylink drivers this issue was solved - it was a driver issue

I'm connecting a Lenovo Thinkvision Displaylink USB external monitor to a Lenovo Thinkpad T450s.

It works fine when I connect the screen to an AC powered USB hub connected, but when I connect the screen directly to the laptop it doesn't draw enough energy and the screen won't work well (flickers, doesn't refresh properly, doesn't paint windows etc.). It works perfectly when connected to the hub attached to the laptop.

The screen came with a usb "y" cable (you know the one that is splitted in two plugs on one end). I think it's precisely meant to draw more power when not used on AC powered hubs. However, I do think that Ubuntu is not sending any power there on the 2nd port and when connected on the laptop it only draws power from a single port, which is insufficient. Tried with two different cables, to no avail. Tried also to make sure that the laptop will charge usb devices (always-on usb 3.0 feature, the screen is usb 2.0 anyway).

I use Ubuntu 15.10.

How would you address this?


Looks like the monitor can work with just 1 usb from the laptop, but I've found more weirdness going on:

  1. if I start ubuntu, then connect the display with either 1 or 2 usb, it will work (i can see the refresh rate is better with 2)

  2. if I disconnect the display, and reconnect it, it won't work. It may turn on and all, but it will refresh very slowly, to the point of being unusable.

  3. if anything related to screen displays refreshes/restarts, such as the displaylink service or for example if I update my software for display calibration (DisplayCal), the screen will flash and will enter in this state where it doesn't paint properly

  4. if I start my laptop with my display connected already (either to 1 or 2 usb) it won't work, it will only function in this bad state - sometimes it will even keep the same appearance as I left it since last reboot (same partially painted areas)

  5. disconnecting and reconnecting again after the screen has entered in this state, no matter what, it will always bring it back in the same unusable mode. I have to restart ubuntu with the screen disconnected, then connect the screen and hope it won't hang

  6. very interestingly, whenever the screen is in this failed state, it will show 2 extra displays in my "Screen" settings - one correctly labeled Lenovo Thinkvision 14" and the other labeled as FNM 0"

this will only show up when display doesn't work correctly

all this leads me to believe is something that could be fixed within ubuntu

  • Did you trie another OS? – Izzno Apr 8 '16 at 17:59
  • yup, worked with Windows, I don't think it's the cable – unfulvio Apr 8 '16 at 18:06
  • but on a different machine, I don't have Win on this machine -- at least I know the cable and the screen are ok – unfulvio Apr 8 '16 at 18:07
  • Have swapped the two USB ports? – eDeviser Apr 8 '16 at 18:18
  • The point is i dont think you can control the poweroutput with software, but I do know some laptops have weak outputs. And my mac has one with more output than the other. – Izzno Apr 9 '16 at 10:17

You might try the tlp package for Thinkpad power management, it provides some USB options:


Read the install instructions carefully, it is incompatible with laptop-mode-tools (uninstall first).

# tlp stat| grep -i USB

shows the info about USB device manamement then.

  • I already had tlp installed, this is the output: ``` USB_AUTOSUSPEND=0 USB_BLACKLIST_WWAN=1 hci0(btusb) : not connected /sys/bus/pci/devices/0000:00:14.0/power/control = on (0x0c0330, USB controller, xhci_hcd) /sys/bus/pci/devices/0000:00:1d.0/power/control = on (0x0c0320, USB controller, ehci-pci) +++ USB Bus 001 Device 003 ID 8087:0a2a control = on, autosuspend_delay_ms = 2000 -- Intel Corp. (btusb) Bus 001 Device 006 ID 045e:07a5 control = on, autosuspend_delay_ms = 2000 -- Microsoft Corp. (usbhid) ``` – unfulvio Apr 11 '16 at 17:33

As has been said earlier, software can't control what power is sent out to what USB ports, however depending on the spec, to which the port was build, will depend on what the electroncis will kick out of it. It sounds like you need to get back to basics to work out what power you have/need.

I've had similar problems with USB and Raspberry pi. The standard USB (2.0) spec says a USB port should kick out 0.6A (600mA), but the max a device can draw is 500mA. USB 3.0 increased that, so some devices (and hence some power supplies) can kick out 2A (2000mA), but devices should draw no more than 900mA.

To illustrate my problem, my Rpi, requires (according to spec) 700mA. If I connect it to a nokia phone charger, it works fine. But when I start using the network, it crashes. The reason, I have a 600mA supply and without networking, that's fine.

I have a 2A supply, and can in theory run both my LCD display and my Rpi from it. However if I connect the Display to the Rpi, and power the Rpi with the supply, it won't work, because the total power draw, would excede the limit on the Rpi. I need a usb hub, that can take the 2A supply and split the power to both devices to get it to work.

So it could be simply that you can't do it, with your laptop. I suggest you check the small print. If the Laptop is USB2, there is a good chance it won't supply more than 1A over 2 devices, that may not be enough for your display.

  • thanks for the detailed explainations -- turns out it worked, but I have weird issues (see my updated question) which prevent me to use the screen properly or reliably – unfulvio Apr 11 '16 at 17:35
  • It sounds to me like a combination of power and configuration. A higher refresh rate will draw more power. If you connect the USB device, then power on the laptop, expect both devices to have started up, before the OS has loaded on the laptop. That would suggest that by the time the OS comes to ask the screen what refresh rate it can handle (in X that's when X starts and loads the config), it'll come up with the max. Expecting X to autodetect a late powerup, after it's started, could be asking too much. – sibaz Apr 12 '16 at 11:19
  • I'm not sure if a displaylink screen would turn on at startup like a regular screen. They require a driver. They do turn on when powered, but nothing is shown until OS startup. It was the same on a windows machine. The difference though is that on Linux those strange things I described happen. If I start Ubuntu with the display plugged in, it will not paint things right, no refresh, unusable. If I start Ubuntu, then connect the display, it will work. But then if something "happens" either to video services or usb, it will flash and enter this state where it doesn't paint things right. – unfulvio Apr 12 '16 at 16:02
  • I'm curious about your percieved differences between windows and linux. Are you sure it's not a hardware difference. Why don't you try downloading a live DVD disk, like ubuntu desktop, and boot up the windows computer, using the linux DVD, and see if the display behaves more like you're seeing under windows. – sibaz Apr 13 '16 at 10:15
  • As an aside, what exactly is the hardware, of the display you have? I have a usb gpu, which presents a DVI connector, when I connect it via USB, and I have USB powered LCD, which I have to connect to an existing HDMI port. Accepting the power issues mentioned, both work fine, with both the Rpi (running pretty current Raspian/Jessie) and myUbuntu Desktop (I'm still running 12.04 LTS, until 16.04LTS comes out in the next few weeks) – sibaz Apr 13 '16 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.