1

I'm trying to install openjdk on Ubuntu 16.04 Beta 2.

After the upgrade from beta 1 to beta 2, openjdk 8 was installed and openjdk 7 was removed. When trying to install openjdk 7 I get the following message:

Package openjdk-7-jdk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or

is only available from another source

Oracle JDK is not an option for me and I have no problem install that. I need OpenJDK.

I have tried:

sudo apt-get update
  • Rebuilding the sources.list from a link I found here in one of the posts.
  • Downloading and completely reinstalling Ubuntu 16.04.

None of the above helped.

closed as off-topic by xangua, Pilot6, Parto, Eric Carvalho, Mitch Apr 6 '16 at 18:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – xangua, Pilot6, Parto, Eric Carvalho, Mitch
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Off-topic? Thank goodness this was raised here and the solution provided below. – HDave Jun 7 '16 at 13:59
  • Maybe not off-topic, but certainly a duplicate. Example: askubuntu.com/questions/761127/… – MDMower Nov 29 '16 at 15:53
1

Same problem, solved using this unofficial repo https://launchpad.net/~no1wantdthisname/+archive/ubuntu/openjdk-fontfix

before you need to install this version of tzdata

http://ftp.uk.debian.org/debian/pool/main/t/tzdata/tzdata_2016c-0%2bdeb7u1_all.deb

  • 1
    the repo works but after trying apt-get install openjdk-7-jdk i get Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: openjdk-7-jdk : Depends: openjdk-7-jre (= 7u95-2.6.4-1ppa1) but it is not going to be installed – Carlyle Felix Apr 3 '16 at 17:17
  • solved using both this: packages.ubuntu.com/trusty-updates/all/tzdata/download and this packages.debian.org/sid/all/tzdata-java/download. i do thank you though pal. – Carlyle Felix Apr 3 '16 at 18:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.