1

I'm using Ubuntu 15.10(EFI 64bit) on MSI GS40 laptop, which has Intel Skylake processor and Nvidia's dedicated GPU.

I couldn't boot to Ubuntu's installation stage without giving GRUB's boot option 'nomodeset' and 'idle=nomwait'.

I searched throughout the internet, found out that I should install Nvidia's proprietary driver to boot without 'nomodeset', and solved that, but still I can't boot without 'idle=nomwait'.

I finished upgrading whole packages and it still can't. I searched again and I found that this option is related to Intel's C-State policy.

I could't progress further from here. Since I saw 'idle=nomwait' disables Intel's C-State function, I want to boot without this because it's laptop that I use outside. So I really have no choice but this, questioning to you guys. Please help me!

PS. Reinstalling it and going into installation screen or live mode, it says

ACPI : EC: Fail in evaluating the _REG object of EC device. Broken bios is suspected

, but I don't know any clue about it.

  • Fixing this type of problem often requires kernel changes. Although Ubuntu provides patched kernels from time to time, such a fix may require an update to a new version, such as 16.04, which is due out on April 21, with a 4.4 kernel, rather than the 4.2-series kernel used in 15.10. That said, I don't know that this pattern will hold true for your specific problem. Maybe there's already a fix available for you. If not, though, keep your eye on 16.04. You might even try the final beta, which is already available. – Rod Smith Apr 2 '16 at 19:31
  • 1
    @Rod Smith, I followed your advice and installed 16.04, but this problem is still the same. I also found that it seems unable to hibernate or shutdown with Intel Graphics, only with the Nvidia's one enabled it can do those. – user3498780 Apr 3 '16 at 3:02
  • In that case, I suggest you file a bug report. – Rod Smith Apr 3 '16 at 13:32
  • When you say "unable to shutdown" – is it similar to askubuntu.com/questions/632591/… ? And what kernel versions have you tried? – unhammer May 1 '16 at 18:47
  • I'm trying to get Ubuntu 16.04 installed on my msi gs40 as well... Did you try the recommendations on this thread. I still haven't gotten it fully working yet either, but the OP on that thread seems to suggest he has. – Matthew Sanders May 18 '16 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.