I'm running 10.04LTS inside VMWare Fusion on a Mac.

The [command] key (aka [windows] on many keyboards) is almost always behaving as if it was [ctrl], even though I done anything explicit to request that behavior.

In fact, in System>Preferences>Keyboard>Layouts>Options>Alt/Win key behavior, 'default' is chosen (rather than the 'Control is mapped to Win keys' option). However, choosing other options there do not seem to change the handling of [command], at least not as tested in the System>Preference>Keyboard Shortcuts app. (No matter what I've tried, [command]-x is always detected as [Ctrl]-x in that app.)

I've tried:

  • various options under System>Preferences>Keyboard>Layouts>Options>Alt/Win key behavior
  • toggling the VMWare Fusion > Preferences > KKeyboard & Mouse > Key Mappings setup which claims to map '[command]' to '[windows]', and restarting the VM in each position
  • the xmodmap lines suggested at https://help.ubuntu.com/community/MappingWindowsKey

And yet, it's clear that all Ubuntu apps aren't merging [ctrl] and [command], because in 'Terminal', [shift]-[ctrl]-c will Copy, but [shift]-[command]-c will not.

If the [command]/[windows] key was recognized as anything else ('Super', 'Meta', 'Hyper'? I don't care as long as it's not 'Control'), then I could achieve my real goal (which happens to be enabling CMD-based cut/copy/paste in PyCharm, while leaving CTRL-X/etc available for emacs-like bindings). I think any solution which manages to make [command]-x appear as something other than [ctrl]-x in Preferences>Keyboard Shortcuts will probably do the trick.


Translating the Cmd key to Ctrl within the VM is a VMware Fusion feature. I believe it can be disabled from either the VMware Fusion global preferences or the individual VM settings.

  • Toggling the VMWare Fusion setting I could find -- the "VMWare Fusion > Preferences > KKeyboard & Mouse > Key Mappings" setting mentioned above -- did not help. I doubt the VMWare settings are the key factor -- if I use 'xev' inside Ubuntu, I see that the [ctrl] and [command] keys are being recognized as different events. But other programs (including notably the standard System>Prefs>Keyboard Shortcuts tool) refuse to see them as any different. And further, now one of the things I tried seems to have caused a persistent reversing of the sense of the [caps lock] key inside the VM. Ugh. – gojomo Nov 21 '11 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.