6

I'm trying to install Docker on my Ubuntu 14.04 VM. I ran sudo apt-get install docker, assuming it would work because, y'know, that's how packages are installed.

Only once the install completed, when trying to run any docker command, I am told that docker is not installed, and that I should try to apt-get it.

I tried both which docker and whereis docker to try to run it from its location but both seem to indicate that docker is not actually installed. If I try to apt-get docker again, I'm told it is installed. I then removed and reinstalled docker to try to fix this, but the same thing is happening. What can I do to resolve this?

EDIT

command output:

j@devstack01:~$ sudo apt-get install docker -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  docker
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/12.2 kB of archives.
After this operation, 65.5 kB of additional disk space will be used.
Selecting previously unselected package docker.
(Reading database ... 113727 files and directories currently installed.)
Preparing to unpack .../docker_1.5-1_amd64.deb ...
Unpacking docker (1.5-1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up docker (1.5-1) ...
j@devstack01:~$ 


j@devstack01:~$ which docker
j@devstack01:~$

j@devstack01:~$ whereis docker
docker:
j@devstack01:~$

j@devstack01:~$ docker
The program 'docker' is currently not installed. You can install it by typing:
sudo apt-get install docker
j@devstack01:~$

j@devstack01:~$ apt-cache policy docker
docker:
  Installed: 1.5-1
  Candidate: 1.5-1
  Version table:
 *** 1.5-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.4-5ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
jn@devstack01:~$

jfarzan@devstack01:~$ dpkg --get-selections | grep docker
docker                                          install
jfarzan@devstack01:~$
  • Please edit your question and add the terminal outputs of the mentioned commands.. – heemayl Apr 1 '16 at 17:27
  • I would add formatted output for which and whereis, but there wasn't any - they did not give any output, indicating that they couldn't find a package named docker. apt-get install indicated a successful install, I can paste the output for that if you think that would be helpful. – jackwise Apr 1 '16 at 17:29
  • Whatever you got.. – heemayl Apr 1 '16 at 17:29
  • What are the outputs of apt-cache policy docker and dpkg --get-selections | grep docker ? – heemayl Apr 1 '16 at 17:35
  • Do you want the docker container? coz just docker is system tray for GNOME.. – heemayl Apr 1 '16 at 17:40
4

docker package available in Ubuntu 14.04 Universe repository provides system tray for GNOME2 applications.

Apparently, you want the docker container. The correct package for that would be docker.io.

Install it by:

sudo apt-get install docker.io

The package version in 14.04 Universe repository is 0.9.1. If you want to install the latest version follow this official guide.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.