Despite the fact there is more than enough room on my screen, Firefox page-right-click menu usually appears pretty small and offers vertical scrolling to view all the items inside it. Some times the effect is like the opposite - a huge free space area is added to the menu after the items. This seems like a problem with XUbuntu (or XFCE). Any experience fixing this?

Example (note the arrow boxes on the top and on the bottom):


  • Do you have the bookmark scrollbar extension installed? Firefox on Xubuntu is the same as Firefox on Ubuntu :) – RolandiXor Nov 3 '11 at 22:09
  • @roland-taylor no, I have no "bookmark scrollbar" extension installed. And I believe Firefox on Xubuntu may not be the same as Firefox on Ubuntu in this issue as the problec can come from combination of Firefox, Ubuntu Firefox extension, XFCE window manager and XFCE Ubuntu theme. – Ivan Nov 3 '11 at 22:22
  • Firefox is Firefox is Firefox :)! The problem may lie in something specific to Xubuntu yes, but it's the same Firefox. Have you tried changing the theme? I'm quite sure the Ubuntu Firefox Extension does not normally cause such an issue. Neither does xfwm4. – RolandiXor Nov 3 '11 at 22:24
  • @roland-taylor, I didn't change any themes - XFCE/GTK/Firefox themes are those XUbuntu default. The only theme I've changed is a window border/header decoration theme, but this can hardly influence pop-up menus. – Ivan Nov 3 '11 at 22:35
  • Can you post a screenshot? Use shutter to capture the menu. – RolandiXor Nov 3 '11 at 22:37

Solved: I got rid of the arrow boxes by downloading the firefox add-on menu editor 1.2.7 this link is for a mac machine but for ubuntu it works the same way: http://www.simplehelp.net/2007/07/29/how-to-edit-the-right-click-context-menus-in-firefox/

  • Fascinating! This helped. And I didn't have to remove any items - just installed it and the bug's gone! – Ivan Nov 3 '11 at 23:41
  • I have that addon too! Maybe that's why I never noticed it :). – RolandiXor Nov 4 '11 at 3:06
  • The solution has suddenly stopped working! The extension is still enabled and I was not updating Firefox or installing any new extensions after I've installed it. But The problem is back :-( – Ivan Nov 9 '11 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.