How can I open a pdf portfolio (pdf file which contains multiple pdfs) that was made with Adobe on Mac or PC?

I've tried FoxIt, Evince, and qpdfview but none of them work.

I get a message saying "For the best experience, open this PDF portfolio in Acrobat X or Adobe Reader X, or later." Unfortunately this is not possible since Adobe does not seem to support these on Ubuntu any more.

  • It's difficult to assess the available options without access to a similar file. If you could provide a link to a PDF Portfolio it might result in further attention to the question. – Elder Geek Jun 7 '16 at 17:30

My solution is based on this answer which suggests a few different PDF applications:

enter image description here

I found that not all these programs actually work for this. In my case pdftk did not work and okular did. One down side with Okular is that you have to export the PDFs contained in a portfolio into individual files:

  1. Open with Okular

enter image description here

  1. Click first item then ctrl+a to select all

enter image description here

  1. You'll be prompted to select a file name and location. You can just keep hitting enter.

It's not as good an experience as using Adobe but it gets the job done.

  • 1
    For me pdftk and pdfdetach worked, while evince and okular failed on Ubuntu 14.04 LTS. – TimeVariant Jun 2 '16 at 16:35
  • Evince with version 3.18.2 is reported to work, available in Xenial. – nealmcb Jul 11 '17 at 2:04

Try evince, the GNOME document viewer

Hit F9 to make the sidebar on the left visible, then at the top of the Sidebar there is the "Thumbnails" menu. Click it.


Then you'll see this:

enter image description here


  • I guess, by default "Thumbnails" is selected.

Menu Then you can change to "Attachments".


This will make the Embedded PDFs visible (see below). You can click on any red PDF icons in the sidebar individually. It will open in a new pdf Window. You can also multi-select (click topmost icon, hold shift, click lowermost icon) the icons and then save them all at once, into individual files.

enter image description here

Although Adobe has discontinued support for Adobe Reader, you can still download a version 9.5.5 from their website, and install it manually:

wget http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

You should be able to view PDF Portfolio files with this version.

  • capital P causes wget to fail – Philip Kirkbride Jun 2 '16 at 8:10
  • Followed this and got an error during install. Now I have Adobe installed but it crashes every time I open it. Ubuntu 16.04 - 64 bit. – Philip Kirkbride Jun 2 '16 at 8:14
  • @PK-Killer You don't need the P option, I will remove it from my answer. – Jos Jun 2 '16 at 8:19
  • it works if you change it to a small p – Philip Kirkbride Jun 2 '16 at 8:26

Type "about:plugins" in the Chrome address bar, and then Disable 'PDF Viewer'. You will then be able to open PDF Portfolio documents as well. Check it out.

  • Well, what operating system are you using, and what app? They would also work if you re-enable Chrome's special security features around risky pdfs, and download the file for local viewing. – nealmcb Jul 11 '17 at 2:06

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.