0

I'm trying to install Ubuntu 14.04.4 on a Acer TravelMate B116-M-C7T3 N3050 notebook. I do not have another OS on this computer, only Ubuntu.

I downloaded the ISO file ubuntu-14.04.4-desktop-i386.iso and created a bootable USB device.

I disabled UEFI in the BIOS (btw. the version of the BIOS is 1.20).

I can use the Try Ubuntu option and it works well. I also get network connection and I can install Ubuntu to the local drive. After the installation succeeds and I press the restart button, Ubuntu will not boot. I just get a black screen without a cursor or mouse pointer.

When using the GRUB bootmanager and selecting the recovery mode, I get the messages:

Loading Linux 4.2.0-27-generic ...

Loading initial ramdisk ...

Below is a cursor but it's not blinking. After this, nothing happens. Also, Ctrl-Alt-Del does not work.

I also tried installing Ubuntu directly from the USB device's boot menu (e.g. without choosing the Try Ubuntu option) but nothing changed.

Since I can "Try" Ubuntu, I assume that Ubuntu does in fact run on this notebook. But why isn't it starting from the local drive? What is the difference?

Update: Everything works fine if I disable automatic updates during the installation. Installing updates manually brings back the black screen. How can I find out which update causes the problem?

Update 2: Couldn't reproduce working installation without updates. Also tried 64 bit version and Lubuntu 15.10. Always ended up with a black screen on startup. Any ideas?

0

After you boot up and the screen is black for some time press CTRL + ALT + F2.

Next, blindly type in your user name and then press ENTER.

Then, type in your password and then press ENTER.

Finally, type in the following command and then press ENTER.

setpci -s 00:02.0 F4.B=00

To get back to your graphical xsession, press CTRL + ALT + F7.

If this fixes your problem, you may need to do the following after installation.

sudo gedit /etc/default/grub

Edit these two lines

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

to read as follows:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

and then run

sudo update-grub

sources

http://ubuntuforums.org/showthread.php?t=1742352

and

http://ubuntuforums.org/showthread.php?t=2118083

  • Thank you but that doesn't work eighter. I wish I could provide more information but all I get is a black screen... – MrSparkle Apr 1 '16 at 13:55
  • @MrSparkle What kind of graphics do you have; I assume you have intel graphics, correct? Also, sometimes the fix for this is to find the correct keyboard combo to increase the screen brightness and to keep pressing this until you can see the screen. – mchid Apr 1 '16 at 14:42
  • @MrSparkle The other thing to do would be to remove "quiet splash" or press F2 during boot to show a verbose output. There may be some useful information printed on the screen if the system is freezing at a certain point during boot. This information may help us tackle and pinpoint the issue. – mchid Apr 1 '16 at 14:45
  • @MrSparkle Also, instead of adding acpi=off you can try editing grub to include acpi_backlight=vendor and or acpi_osi=Linux to get it to work. – mchid Apr 1 '16 at 14:48
  • Yes, the notebook has Intel HD graphics. From what I understand, there is no need to install or update drivers for this. Also, Ubuntu runs without problems when booting from a USB device. – MrSparkle Apr 1 '16 at 18:49
0

I got it working. Here's what I did:

  • In the BIOS setup, I enabled the UEFI secure boot option
  • I installed Ubuntu 15.10 64 Bit from the USB Device
  • Then I had to disable the UEFI secure boot (legacy mode)

Instead of the black screen there's a purple screen now, and after a few seconds there is black screen again. But: If I press Enter, there's some flickering and graphics mode changing going on and afterwards, finally, I can see the login screen and everything works fine.

The only thing that is not working with that device is the hibernation mode. Well, the Acer TravelMate is not a certified Ubunutu device but if you follow the above instruction it seems to work just fine. It's very fast and beautiful.

Thank you for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.