14

When I try to open the PDF file I need it looks this way (I have tried Evince, Chrome and Firefox), saying

Please wait...

If this message is not eventually replaced by the proper contents of the document, your PDF viewer may not be able to display this type of document.

You can upgrade to the latest version of Adobe Reader for Windows®, Mac, or Linux® by visiting http://www.adobe.com/products/acrobat/readstep2.html.

For more assistance with Adobe Reader visit http://www.adobe.com/support/products/acrreader.html.

I have found an explanation saying

Certain PDF files (dynamic XFA forms) created in Adobe LiveCycle can only be opened in Adobe Reader and Adobe Acrobat. When you try to open these files in an alternative PDF viewer, then you will see this error message.

How are such files meant to be opened on Ubuntu given the official Adobe Acrobat Reader package is deprecated?

It's not a real problem for me practically as I have actually managed to install Adobe Acrobat Reader 9 (BTW I am, however, afraid this ancient version is going to start having problems with opening new files of this kind soon) on Xubuntu 15.10 a reasonably tidy way by unpacking the old Ubuntu DEB package, putting the necessary files to a subdirectory in /opt and editing the Reader's launch scripts but I believe it's a pretty serious issue for using Ubuntu in commercial/academy/government environments so there is to be a more proper way.

  • 1
    I could open it with Adobe Reader 9 for Linux. But it is not officially available for download any more. – Pilot6 Mar 31 '16 at 19:55
10

Try Master PDF Editor (proprietary). The free version is good for viewing, but for editing probably not (I read that it leaves watermarks).

You can also use the outdated, unsupported, probably very insecure, old Adobe Reader 9 for Linux.

  • I used Master PDF Editor and was really surprised that it can open these types of files! As far as I know, this is the only non-Adobe solution I've ever seen, wonder how they did it?! Kudos to them and thanks for the answer – Hamman Samuel Dec 4 '17 at 1:23
  • It opened it but it doesn't allow editing it. It says "This form is compatible only with Adobe Reader or Acrobat". – David Graham Dec 17 '17 at 16:07
  • Master PDF Editor works! – Goran Horia Mihail Jul 4 '18 at 11:41
5

Recent drafts of PDF next-generation (ISO 32000-2) note that there was a vote to deprecate XFA:

Editor’s note: XFA forms have been deprecated from ISO 32000-2 in accordance with the outcome of the letter ballot following the Pretoria meetings.

As explained at 3 Alternatives to the Adobe PDF Reader on Linux | Linux.com | The source for Linux information, features like Extended form filling (such as XFA Forms) and Embedded 3D models won't work in most open source implementations.

So I suggest pushing back to the people producing the documents, explaining that they are not accessible to people in a variety of situations, are not supported by e.g. the Chrome PDF viewer or open source viewers, and that they thus increase the attack surface and increase security risks. So they should drop use of XFA.

  • 4
    +1 for the advise not to inflict these annoying documents on the world in the first place! – cbare Sep 16 '16 at 16:10
2

I just now used the free online service at https://speedtesting.herokuapp.com/pdfxfa/ "XFA PDF to Normal PDF (XFA Form Flatten)". Worked perfectly for me, I used it for just one fillable pdf that I couldn't view or print because it was in this annoying XFA fillable format :-(

1

I installed Acrobat Reader for ubuntu using:

https://linuxconfig.org/how-to-install-adobe-acrobat-reader-on-ubuntu-18-04-bionic-beaver-linux

While this is an old version of the Acrobat Reader I was able to open that special file. Note: I had to download the needed pdf file to my desktop and open this file using the Acrobat Reader

-1

Chrome should work BUT Chrome first needs the NotablePDF plugin to actually view the PDF. Make sure you have that plugin. That should get you smooth sailing viewing PDF via a browser. Can be found in the Chrome App Store.

Okular is supposed to be one of the most stable PDF readers on Linux systems. It is the default viewer in KDE. It has a little more features than Evince, which I saw you've already tried.

Good Luck and Enjoy.

  • Notable now known as Kami PDF does not work – Stevie G Jun 21 '16 at 6:51
  • I've tried this one and the effect is the same, i. e. not working. Thank you for the suggestion anyway. – Ivan Feb 19 '17 at 17:34
  • 1
    I've had no problems filling out Adobe forms in current versions of Chrome by default. no plugins required. – Elder Geek Feb 13 '18 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.