2

People have asked about this bug before, but it hasn't really been answered yet.

Redshift used to work fine for me, but now it doesn't any more. I don't know how that happened. There seems to be some problem with the geoclue service or something.

Can't we

  1. Manually toggle Redshift on and off, without needing any location?
  2. Set the location manually?

I don't really care about any of the automation, I just want a working screen dimmer. There is an alternative called "Iris" but it's a paid app.

Here is what happens

 arun@arun-GP70-2OD:~$ redshift
 Trying location provider `geoclue'...
 Started Geoclue provider `Geoclue Master'.
 Using provider `geoclue'.

 ** (process:4125): WARNING **: Could not get location, 3 retries left.


 ** (process:4125): WARNING **: Could not get location, 2 retries left.


 ** (process:4125): WARNING **: Could not get location, 1 retries left.


 ** (process:4125): WARNING **: Provider does not have a valid location available.
 Unable to get location from provider.

The same thing happens when I use gtk-redshift and redshift-gtk.

  • 1
    You can give redshift a location, for example, the man page has one for Copenhagen, Denmark: redshift -l 55.7:12.6. – mikewhatever Mar 31 '16 at 19:43
  • @mikewhatever Yes, it works! – Revetahw Apr 1 '16 at 5:24
4

As per the documentation for the configuration file, you can specify manually location, color temperature, etc…

For example, if you were in Copenhagen, you could run redshift-gtk -l 55.7:12.6. That will also launch the panel indicator.

  • Yes, I was able to run it with this redshift -l 12.1:79.3 -t 5700:2000 -g 0.8 -m vidmode -v and it works great. But does this mean that I can no longer see the GUI, like the panel icon? – Revetahw Mar 31 '16 at 20:06
  • No, if you modify the configuration file, you can have redshift-gtk start at login still, and the options will be preserved across logins/reboots, so you don't have to run redshift manually every time. – dobey Mar 31 '16 at 20:10
  • 1
    I guess you merely need to replace redshift with redshift-gtk in the command above. – Sadi Mar 31 '16 at 20:12
  • @Sadi I'm sleepy, I'll get back to you and Dobey tomorrow. This is very interesting. I've gotta make this work. – Revetahw Mar 31 '16 at 20:14
  • 1
    No problem. I actually use the command killall redshift && redshift-gtk [MyOptions...] in a shell script, and then enter its full path in the ~/.config/autostart/redshift-gtk.desktop file's Exec= line. – Sadi Mar 31 '16 at 20:37
0

There seems to be a geoclue-2.0 available, which solves the issue for me (Ubuntu Mate 16.04, redshift-gtk) and for this guy (Linux Mint).

I removed redshift first (just a security step) by

apt-get purge redshift

And then did how instructed in russian:

sudo apt-get install redshift-gtk geoclue-2.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.