5

Using Ubuntu 15.10. Configuring input using the Input Method Configuration screen. Whenever I change Extra key for trigger input method it works for only that session. Once I restart the computer it goes back to the default value of SHIFT Both which is annoying.

Is there a config file that is being overwritten every time I boot up? How can I prevent this?

6
  • So you're just running the normal flavour of Ubuntu? And how exactly are you accessing the settings you speak of?
    – user364819
    Mar 31, 2016 at 15:25
  • thanks and I solved this problem now ,you can use: fcitx-configtool to get this settings
    – Larry Yang
    Mar 31, 2016 at 15:26
  • If you have found the solution please post it as an answer to help others in the future.
    – user364819
    Mar 31, 2016 at 15:27
  • Yes I'm going to post the solution tomorrow, it's pretty late in China now, so I will post it tomorrow morning.
    – Larry Yang
    Mar 31, 2016 at 15:32
  • Right, yes, of course, I understand.
    – user364819
    Mar 31, 2016 at 15:47

5 Answers 5

4

I had the same problem, until I realized that I was using Sougou Pinyin on top of fcitx. In the settings of Sougou Pinyin, there is a hotkey (the default is SHIFT) for switching between Chinese and English. I believe it overwrites the settings of fcitx. I changed the hotkey to none and now the settings of fcitx are kept. If you are using Sougou Pinyin as I do, that might be the problem.

1
  • Thanks, I think this is better than setting 400 for the config file.
    – Q. Qiao
    Aug 5, 2019 at 18:41
4

First you can use this command fcitx-configtool to open the fcitx config window,then you can change Extra key for trigger input method to whatever you want.

Then you can cd into the fcitx config folder: cd ~/.config/fcitx and use chmod 444 profile to change the permission of the profile to read only, so that no one can change back to default value.

1

@LarryYang 's solution didn't work for me, when I restarted my laptop, it seemed that a new profile was created and replaced the old one even after chmod +444 profile is used.

After some experiment I'm sure it is a behavior introduced by sogou pinyin instead of fcitx. Uninstalling sogou pinyin using sudo apt-get purge sogoupinyin saved my day.

1

@Larry Yang's answer did not help me either. ~/.config/fcitx/profile seems to re-create and replace itself on each login.

Instead, edit ~/.config/fcitx/config

Change SwitchKey=SHIFT Both to SwitchKey=Disabled or whatever you like.

After saving and exiting, use chmod 400 config to make the configuration persist between logins.

0

Changing permission of the config file works for me.

  • disable switchKey via fcitx-configtool
  • run chmod 400 ~/.config/fcitx/config
2
  • Seems to be pretty much the same as this answer?
    – Zanna
    Aug 7, 2017 at 10:57
  • Is this a "thanks worked for me too" comment to the link @Zanna posted? Aug 7, 2017 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.