0

I have to recover data from a server running Ubuntu 13.10 for a client.

I need to find out what data is on this machine and then recover it to an external drive. The drives that were accessible via the network showed that the shared drive (950GB) was nearly full, but clients could only see 3 GB (which they backed up prior to removing the server). I have what they were given as the administrator ID and password and I can log in using that info. And so far, that's about as far as I got!

I tried to load some kind of GUI to make it a little easier. I found and ran this command:

sudo apt-get install ubuntu-desktop

After screenfuls of data flashed by for a few minutes it appears it was trying to download something and could not. My guess is maybe the server had a fixed IP and isn't working properly on the current network. Lots good examples seemed to use an interface using:

sudo service network-manager start

But that turned out to be an unrecognized service.

After more research I decided to try to manually edit the network configuration file:

gedit /etc/network/interfaces
edit /etc/network/interfaces

gedit wasn't installed and the second gave an error about permissions (again using the only admin ID/PW they have) but then I realized it didn't really matter what I typed after edit - it still simply said I don't have permission, so may be another misleading message.

So it seems I can't really do much without a proper GUI. Any tools or interfaces I try to load seem to need internet access (seems not much is actually included with this O/S). And I can't even see much less fix the network configuration.

If anyone out there has any suggestions on how to proceed to it would be greatly appreciated.

  • 1
    Try: cat /etc/network/interfaces to just see what's in that file, and sudo nano /etc/network/interfaces to edit it. Run lsblk to see what the current disk layout is, df -h to see what the disk usage is. Also, Ubuntu 13.10 is an end-of-life release, you aren't installing anything on without following How to install software or upgrade from old unsupported release?. And your client needs to start hiring better people. – muru Mar 31 '16 at 4:44
  • Use nano to edit files in a Terminal environment. – user423626 Mar 31 '16 at 4:44
  • Thanks for the suggestions. Was able to reconfig network so have internet. Most things tried to load still failed - expect as you mentioned due to being old release (no idea why this guy would use an EOL version!) Using recommended article was able to edit sources to add old-releases. Currently updating. Not done - will be back to this a little later. Just wanted to give heads up and say thanks! – Landon Mar 31 '16 at 21:52
0

If you're uncomfortable at the command line and wish to use GUI tools you could make a bootable thumb drive using just about any of the available live linux distros. Once booted you can use the file manager of the distro you chose to mount the internal and external drives then move the data between them.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.