3

I just bought this USB wifi adapter, TP-Link Archer T2U AC600, from BestBuy (Canada) since it stated that it had linux support on their website. I have tried the driver software from the TP-Link website. It fails to even make.

http://www.tp-link.com/en/download/Archer-T2U.html#Driver

I tried their FAQ as well for installing on linux. http://www.tp-link.com/en/faq-1076.html

That lead me to here: https://github.com/lixz789/mt7610u_wifi_sta_v3002_dpo_20130916

This driver also fails to install: make install make -C /home/me/tplink/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux -f Makefile.6 install make[1]: Entering directory '/home/me/tplink/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux' mkdir: cannot create directory ‘/etc/Wireless’: Permission denied rm -rf /etc/Wireless/RT2870STA mkdir /etc/Wireless/RT2870STA mkdir: cannot create directory ‘/etc/Wireless/RT2870STA’: No such file or directory Makefile.6:454: recipe for target 'install' failed make[1]: * [install] Error 1 make[1]: Leaving directory '/home/me/tplink/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux' Makefile:501: recipe for target 'install' failed make: * [install] Error 2

Edit: I wanted to add the lsusb output as well. But it is not even listed there on Ubuntu 15.10 64bit.

Edit2: Tried the sudo make command. It made without errors this time. I followed the rest of the instructions on the git site. Once I installed and rebooted, the adapter is still not being detected and the software caused an internal error.

Edit3: I checked for the mt76‌​01u.ko file. It is in the correct folder. I will post the lsusb later.

Is there any solution to this? If not, can someone recommend me the a good recent usb wifi adapter for Ubuntu 15.10 (and possibly 16.04)?

  • Run sudo make install and see if it works. Tell me if it does. – TheWanderer Mar 31 '16 at 0:20
  • I believe the driver mt7601u is already included in 15.10. /lib/modules/4.2.0-34-generic/kernel/drivers/net/wireless/mediatek/mt7601u/mt7601u.ko Please edit your question to include the result of: lsusb and also: rfkill list all. – chili555 Mar 31 '16 at 0:58
  • I ran sudo make install (no errors this time), followed the rest of the instructions on the site, and rebooted. The adapter still is not detected, and it caused an internal error. – GSM-S Mar 31 '16 at 7:35
  • Take a look here: askubuntu.com/questions/806334/… – vitaly.v.ch Jul 14 '18 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.