In Lubuntu 15.10 even though in /etc/default/keyboard it is set that XKBOPTIONS="compose:rctrl", no compose key works when using Right Ctrl. The system doesn't even register it as compose key (any letter I type after pressing it is printed on screen, it doesn't wait for a combination).

2 Answers 2


I don't know if this applies to Lubuntu, but here's the solution for regular Ubuntu:

/etc/default/keyboard doesn't seem to matter. It doesn't have XKBOPTIONS filled in on my system even though I have the compose key enabled. What does matter is the gconf setting 'org.gnome.desktop.input-sources xkb-options'. You can edit it via dconf or use terminal like so:

Check the current value:

gsettings get org.gnome.desktop.input-sources xkb-options

If the above just returned empty brackets, run this, and you're done:

gsettings set org.gnome.desktop.input-sources xkb-options "['compose:rctrl']"
  • Nope. I did that and now the output is ['compose:rctrl'], but the rctrl still doesn't function as a compose key...
    – stanny
    Mar 31, 2016 at 12:00
  • Maybe you need to log out and back in. Try restarting too, for the heck of it.
    – wjandrea
    Apr 10, 2016 at 0:38
  • Tried that as well, but still nothing.
    – stanny
    Apr 13, 2016 at 21:19

Keyboard Layout Handler seems to override the system settings, so this is how you solve the problem:

  1. Right-click on the language flag in the bottom right.
  2. Select "'Keyboard Layout Handler Settings' Settings".
  3. Under "Advanced setxkbmap Options" input compose:rctrl and click on the little "save" button in the right end of the input box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.