0

I have a problem with Ubuntu 15.10 I have in my computer windows 10. Some days ago i decided to install Ubuntu in partition so i can have both in the same hard drive. The problem is that i cant get into ubuntu, i dont have the grub up so i always go to Windows in default mode. The only way to go into ubuntu is with the CD of installation, when im on the grub of the cd i press Esc, then i text exit in command lines and i go to a boot manager in which i can choose the ubuntu system. Its a strange think because it is the only way i can get into ubuntu, i will like to solve this problem. I try many tutorials already of solving this problem. I didnt get any solution so i will like to ask u before doing another tutorial. Thank u

2

2 Answers 2

1

It looks like your Ubuntu boot loader (GRUB 2) is not properly registered with the firmware. You should be able to fix it as follows:

  1. Boot the installer in "try before installing" mode.
  2. Open a Terminal window.
  3. Type sudo apt-get install efibootmgr to install the efibootmgr tool.
  4. Type sudo efibootmgr -o 0003,2001,0000,2002,2003. This adds your Ubuntu entry (0003) to the start of the boot order, as shown in lines 589-599 of your Boot Repair output.
  5. Reboot.

That should fix the problem. Unfortunately, there are some badly broken EFIs that tend to forget their boot orders or ignore anything but Windows boot entries. If you've got such a computer, your best bet is to return it to the store for a refund and get a new computer that's not broken. If that's not possible, Boot Repair has an option on its Advanced menu to back up and rename boot files that might work, but it's an ugly hack of a workaround that might not last all that long, since Windows might easily undo it.

5
  • There are more choices here. If he has a Lenovo you have something called Default OS Optimized in BIOS which prevents you from booting linux. Including Secure boot. And looking at the output he posted, it looks like he installed Legacy...
    – Izzno
    Mar 30, 2016 at 0:38
  • The pastebin output clearly indicates an EFI-mode installation (EFI/ubuntu/grubx64.efi and related files on the ESP, efibootmgr output shows an ubuntu entry [although it's not in the boot order]), with no indication of BIOS-mode installation (no BIOS-mode boot loader in the MBR, no BIOS Boot Partition).
    – Rod Smith
    Mar 30, 2016 at 13:15
  • Yes I see that now, the strange lineup of partitions got me confused, and so i deleted my answer.
    – Izzno
    Mar 30, 2016 at 13:34
  • Hi, first thanks for your answer, i did what u said but i didnt get any result. Do i have to reinstall Ubuntu or something like that? Can i do this process when i get into my ubuntu SO? Mar 30, 2016 at 14:39
  • Chances are your firmware is buggy/defective. There are dozens of questions/answers about this like this one and this one and this one. Your best bet is to return your defective computer for a refund, but nobody ever seems to want to follow that advice.
    – Rod Smith
    Mar 30, 2016 at 17:21
1

All Acers have unique requirements for setting UEFI supervisor password and setting "trust" on Ubuntu/grub boot files. Some versions may need update to latest UEFI from Acer.

Acer Very latest UEFI/BIOS works, downgrade not required:

http://ubuntuforums.org/showthread.php?t=2298380&p=13419141#post13419141

Acer E5-573G, downgrade UEFI, supervisor password & trust on Ubuntu efi boot files.

Getting a black screen when installing or Live booting Ubuntu (any version) in my laptop

Acer Aspire E15 will not dual boot, many details

Acer Aspire E15 will not dual boot

1
  • Hi, actually my computer is an acer aspire v nitro vn7-571g. So maybe i have that problem. I will try to follow that post. I will tell u the result. Thanks Mar 30, 2016 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .