It has been a week trying to repair Ubuntu. It doesn't boot. I started getting "error: environment block too small" or "error. file normal.mod not found" or "error: invalid arch-independent ELF magic."

Now I am getting- Uncompression error. System halted. After trying to reinstall Ubuntu from scratch, then Win7 and now Ubuntu 15.10.

-I checked the RAM with grub and its OK. -Boot repair didn't work. This is the report http://paste.ubuntu.com/15554765/ -No dual boot. -ISO is OK. I did the MD5SUM. - Live USB works and installs fine. The problem is when rebooting without the USB.

I tried installing Win7 and I got the same error when booting.

I am completely lost on this. I read many questions on ask Ubuntu but nothing worked.

  • Did you find the cause of this or a way to fix it? The same thing happens with me as well – Ahmed Anwar Oct 20 '17 at 18:27
  • Yes. At the end it was a hardware issue. The hard drive was damaged. I replaced it and never happened again – Ulises Oct 22 '17 at 0:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.