0

During installation of android SDK the permission problem appears. It says permission denied.snapshot attached as follows.How to resolve this problem?

enter image description here

  • Did you try it with sudo? – Mahdi Mar 29 '16 at 18:41
  • no, i am a new user on ubuntu. doesn't know many thing. – Zohaib Siddique Mar 29 '16 at 18:42
  • if you know then please guide me – Zohaib Siddique Mar 29 '16 at 18:43
  • Repeat that command like this: sudo ./android – Mahdi Mar 29 '16 at 18:47
  • cd /media/zohaib/01D0BABD567AD460/android-sdk-linux/tools then write sudo ./android but it says there is no command found – Zohaib Siddique Mar 29 '16 at 18:50
1

You can run any command with sudo in order to give super user privileges to that command. So here you can write sudo ./android and then it asks your password.

Before that please check if your file (android) has executable permission or not. You can check that with ll android similar to the image below:

enter image description here

If there is not executable permission you can add x permission with this command: chmod +x android.

And you're done.

  • i tried it it asks password after all it says there is no command found\ – Zohaib Siddique Mar 29 '16 at 18:51
  • ll android shows -rw------- 1 zohaib zohaib 3498. whats it mean? – Zohaib Siddique Mar 29 '16 at 19:08
  • also tried chmod +x android. it again shows permission denied – Zohaib Siddique Mar 29 '16 at 19:10
  • try with sudo chmod +x android – Mahdi Mar 29 '16 at 19:12
  • again permission denied? – Mahdi Mar 29 '16 at 19:16
0

From http://developer.android.com/sdk/installing/adding-packages.html which I assume is the step you are on as you used cd tools

Mac/Linux: Open a terminal and navigate to the tools/ directory in the location where the Android SDK was installed, then execute android sdk

Try using android sdk instead of ./android

  • i write /tools android sdk but it shows permission denied – Zohaib Siddique Mar 29 '16 at 19:26
  • permission denied – Zohaib Siddique Mar 29 '16 at 19:27
  • how to give permission ? @user1326419 – Zohaib Siddique Mar 29 '16 at 19:33
  • Try downloading the sdk onto your hard-drive instead of the mounted drive and trying from there. – user6031769 Mar 29 '16 at 20:02
  • I copied sdk to my Downloads location but again it says command not found @ user1326419 – Zohaib Siddique Mar 30 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.