1

I have the following config:

HP 210 mini Intel Atom 1.6 ghz CPU Crucial MX100 256GB SSD 2GB RAM

After installing 15.10, the system displays grub loader. After selecting the boot option, the ACPI PCC error and boots to the initramfs command line. It does not matter what I select. Win 10 was previously installed. I wiped out the existing partitions and created a single ext4 partition w/o a swap file. I've read everything about optimizing an SSD after install, making sure TRIM is working, etc.

Am I missing something? Any help is appreciated. I've read through the other thread (installing Ubuntu on SSD) which is geared more towards post-install optimization of the filesystem for SSD. Cannot take screenshots as the system will not boot, but photo is linked below.

screenshot after grub loader

First, I attempted to mount the filesystem from the live installer:

sudo mount /dev/sda /mnt mount: wrong fs type, bad option, bad superblock on /dev/sda, missing codepage or helper program, or other error

then, I tried to install grub-repair per the suggestion:

sudo apt-get install boot-repair

unable to locate package grub-repair

I instead installed boot-repair and ran the utility. Here's the pastebin link: http://paste.ubuntu.com/15552199/

7
  • Possible duplicate of Installing Ubuntu on a SSD Mar 29, 2016 at 5:40
  • @MostafaAhangarha None of the answers there touch the problem in the question here, which is related to the boot setup but missing essential and accurate information about the installation (the actual error messages displayed on screen, boot-info, boot mode, installation logs, partition table info etc).
    – LiveWireBT
    Mar 29, 2016 at 7:33
  • LiveWireBT is correct - the other thread is more about optimizing the SSD post-install. Cannot take screenshots or do a log dump as it won't boot but I will post pics here. And I must be honest, I'm no Linux superuser ;) Mar 29, 2016 at 13:48
  • "ACPI PCC error" is a -harmless warning- and not the problem. Your problem is the thing that happens immediately after that. In general it results in a black screen indicating problems with the video card. "initramfs command line" ... it should report an error notice ;-)
    – Rinzwind
    Mar 29, 2016 at 13:58
  • Thanks, just posted the screenshot. I can boot from USB into the live image. Mar 29, 2016 at 14:04

1 Answer 1

1

What media are you installing from, USB or CD/DVD?

Also, you could try to use grub-repair from the live usb/disc. When booted, install grub-repair $ sudo apt-get install grub-repair Then you can run it with the command $ grub-repair Then click automatically fix.

If that does not work, there might be a problem with the bootloader. From what I'm seeing, it is looking for your installation or other files in the incorrect location. I have the same setup, no SWAP, SSD, but I have Xubuntu. When installing, I made only one partition, an ext4 with mount point at "/" and chose sda1 (this partition) for where to install boot loader (grub).

I've never seen this error before but I think it's saying it cannot find your hard drive. But then seemingly loads ititramfs from it? Idk, try the possible solutions above and get back to me.

2
  • Tried using boot-repair. Still will not boot past the initramfs screen. System was installed in the manner you described (ext4, mount point /, sda1) Mar 29, 2016 at 15:39
  • It seems as though the kernel is not loading the module to recognize the hard drive, hence (- Missing modules (cat /proc/modules; ls /dev) ALERT! /dev/...../..... does not exist.) If the live linux loads, it should be copying the same kernel and modules to the install, which obviously recognized your device. Try deleting the partition table and create a new one, then create the ext4 partition and continue from there. My partition table used to get screwy and would mess things up in a weird way. I would also make sure the UUID is the same as your HD (sudo blkid). sorry for late response..
    – knuxyl
    Apr 10, 2016 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.