I use Ubuntu 15.10 (running from the disk) I run diagnostics and the disk doesn't seem to have any problems nor my drive should have (it and "expensive" bd-r DVD-r drive from a big brand and never had issues in the past or in windows I also tried to use a second drive without any difference)

I loads the GUI am able to do whatever install I want or run what I want without a problem but then after some random time interval everything freezes the mouse doesn't move the keyboard doesn't react (caps lock etc when push doesn't flash any LED, etc.) and the only solution is hard reset

My CPU is AMD FX 8320, my mobo ASRock 970 pro 3 rev 2.0, 16 GB of RAM, Nvidia GTX 650 ti 2GB RAM. I also run 2 monitors.

It must be Ubuntu and not a specific task or process (like flash) because it freezes even if I don't do anything (like being afk and returning after a few minutes only to see that it froze... )

In fact I never shutdown the computer because EVERY time I boot Ubuntu it freezes... its got so frustrating that I want to hammer my tower to pieces no matter if I know that its not likely a hardware failure.

I installed Ubuntu to a CompactFlash card. It was disastrous! It was slow as hell the boot time took longer than the DVD and the system open error messages after log in and hang itself, and I was surprised since using Knoppix on CF card was like I was using a PCIm.2 SSD like super fast with no errors. Even Windows 2000 is super fast using a CF card.

Then I tried installing it on a 32GB usb3 flash drive and the problems still exist although after the initial installation and first boot it was stable for quite a few hours like more than one or maybe two. It never happened with live DVD which did freeze on random times, but usually if not always it took less than a hour.

but it freeze nonetheless (I was running and update check which took like 30 minutes to an hour+ despite my fast internet connection -VDSL 30Mbit, downloading at ~3MB/s- it finished downloading the files I think and it froze when unpackaging was like at ~90%)

And it was generally VERY slow (not so horribly slow as the CF which too like 20 seconds to click on log in other 5-10 to blink the cursor on the pass entry etc) it had like one to five+ delay to respond to most of my actions (sometimes it was instant but very rarely)

Again I was surprised... I expected much better (since using the same stick for Windows usually instantly responded to read and write of large files and read writing speed was more than 80MB/s )

I left it open frozen as is because of frustration and gone to sleep next day (today) I shut it down and boot it up again and it was much faster (although not even close to Knoppix running on CF) it was like having a HDD/SSD hybrid, but now it froze like within a minute after login. Then I hard rebooted it and SURPRISE it booted normally I tried to update the AMD microcode and the Nvidia driver before even being able to click on "Apply" after choosing them

It froze.

Then I rebooted again trying to do the same thing it worked. Then I restarted the system normally by clicking shutdown and restart (for the first time)

but during the restarting it froze before loading the GUI with a console error like: /dev/mapper/something-vg-something clearing this and that or something like that then after hardreboot I run ubuntu recovery and it loaded shell on the same place (after telling me that this thing on the mapper directory wasnt found - sorry just woke up can't remember.) then I rebooted

and surprise it worked.

Now typing this message trying to be hasty while nervous of a sudden freeze again (sorry for the typos and for the long post cant think clear right now) but... and Ubuntu froze before I was able to finish the sentence. Hopefully Stack Exchange saves the text.

1 Answer 1


I have had a similar problem, and the only thing that works for me is running an older kernel. There is a list of stable kernels here: https://wiki.ubuntu.com/Kernel/Dev/ExtendedStable

I have been using 3.19 without any problems.


Here is a previous related question: How do I install an old kernel?. The answer describes how to install an old kernel.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .