I haven't been getting any low disk space warnings even though nautilus tells me I've got little space left (varies between reporting 1.4G free to complaining that it's unable to save a small file because disk space is exhausted)? I want to have it reappear so I can write up a log of the disk space fluctuating wildly between 1.4G to 0 bytes so I can ask questions about that.

  • 1
    It is fairly unclear what you are asking. What exactly do you want to accomplish? What warnings do you refer to? – Thomas Ward Mar 28 '16 at 3:21
  • 2
    Ubuntu used to give me a pop-up with a "only xxx amount of disk space remains". Now it doesn't. How do I get it to give me the warnings again. – Paul G Mar 28 '16 at 3:24
  • I see what you are meaning: test out my answer and see if it helps... – andrew.46 Mar 28 '16 at 6:54

To enable these low disk space warnings (tested on Trusty Tahr 14.04 and Precise Pangolin 12.04) run the following:

gsettings set org.gnome.settings-daemon.plugins.housekeeping active true

Or to disable the low disk warnings run the following:

gsettings set org.gnome.settings-daemon.plugins.housekeeping active false

If you prefer a gui you can see these same settings with the dconf editor:

sudo apt-get install dconf-tools

On Trusty you can press Ctrl+F to access the 'Find' feature and search for 'disk space', on Precise the 'Find' functionality does not work well and you must manually drill through the following:

org > gnome > settings-daemon > plugins > housekeeping

Here you can not only activate and deactivate the disk warning but you can carefully change many other settings:

enter image description here


  • Well, I tried using the GUI, the "find" function in the "menu" doesn't seem to exist. Of course there's nothing labelled menu in the first place. Do I have to go Mac to get stuff that actually works? – Paul G Mar 29 '16 at 13:48
  • I did the terminal thing. No change so far but we'll see. Thanks for the help. – Paul G Mar 29 '16 at 13:52
  • @Paul: Press Ctrl+F to access the 'Find' feature of the dconf editor... – andrew.46 Mar 30 '16 at 9:17
  • 1
    Maybe this isn't working because I have 12.04LTS? – Paul G Mar 31 '16 at 4:46
  • That is a definite maybe :). I will make a 12.04 VM and test... – andrew.46 Mar 31 '16 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.