2

Does anyone know if the the T460s will eventually have official support, like the T450s? Or would that have happen already?

  • Ubuntu 14.10 is not supported anymore, but my T560 runs fine with 16.04. – LiveWireBT Mar 28 '16 at 3:50
  • What about 14.04? – Jeff Mar 28 '16 at 6:03
  • 1
    Using Ubuntu 15.10 and having installed Ubuntu extras, everything appears to work except two things: 1) freezes after closing lid and re-opening it, 2) freezes when plugging in anything to HDMI or Display Port. – josephdpurcell Mar 28 '16 at 21:59
  • I have T560 with 16.06 and I also have the same two problems: 1. freezes after closing lid on battery, 2. freezes plugging in second monitor on HDMI. – Елин Й. Apr 4 '16 at 16:22
  • The "lid close freezes the system" bug is fixed on Wily now, and fixes are queued for Vivid and Xenial. bugs.launchpad.net/intel/+bug/1559923 – Adrian Apr 17 '16 at 11:40
4

I tried Lenovo T460 with Ubuntu 14.04 LTS, 15.10, and 16.04 Beta 2 and they all had two issues:

  1. Using an external monitor would freeze the system. (I tried many combinations, e.g. plug-in then turn on, plug-in at login screen, different cables, etc)
  2. Closing the lid would cause the system to freeze and not go to sleep.

After updating to linux kernel 4.5 you can attach an HDMI monitor, but mini Display Port (mDP) will still cause the system to freeze, and closing the lid still causes the system to freeze.

Important related notes:

  • You have to boot the system with the HDMI monitor attached. Only then can you plug and unplug the monitor without the system freezing.
  • If you have Intel Virtualization Technology and Intel VT-d Feature enabled under "Security" in the bios (e.g. for use with VirtualBox), you cannot plug in an external display or the system will freeze.
  • I tried Fedora 23 and Linux Mint 17.3, both with similar problems described above with Ubuntu.
  • I am currently using Fedora 24 and find it to be the most stable. I still can't use mDP and can't put it to sleep without a crash, but I can at least plug-in and remove HDMI while booted.

See also this reddit thread for a conversation regarding Ubuntu and displays with the T460

| improve this answer | |
  • Lid close used to crash the system for me, but I and others see this as fixed now. – Jonathan Hartley May 2 '16 at 17:51
  • How did you install the 4.5 kernel? Can I get it via xenial-proposed, or must it be done manually? – anr78 May 25 '16 at 6:46
  • Just noticed the link to Kernel/Mainlinebuilds in the Reddit thread... – anr78 May 25 '16 at 6:51
1

I'm on 16.04 LTS. Upgraded bios to 1.11 and installed kernel 4.5.2-040502-generic. HDMI works, and yesterday it worked all day long. Today, however, it freezes all the time. The last thing I see in the kernel logs is this: http://pastebin.com/qpTJU9Bu

Edit: with kernel 4.6 hdmi seems stable for me. What I did:

#!/bin/sh
mkdir -p /tmp/kernel46 && cd /tmp/kernel46
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/linux-headers-4.6.0-040600_4.6.0-040600.201605151930_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/linux-headers-4.6.0-040600-generic_4.6.0-040600.201605151930_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/linux-image-4.6.0-040600-generic_4.6.0-040600.201605151930_amd64.deb
sudo dpkg -i *.deb
sudo reboot
| improve this answer | |
  • Your answer does not seem to answer the OPs question. Please be specific to the question. – ankit7540 May 27 '16 at 13:14
  • I fully agree. Forgot myself when fiddling with this and treated it as a forum post. Out of curiosity: The other answer does not answer The OPs question either, so why is my answer (rightly) downvoted, but not that answer? – anr78 May 29 '16 at 18:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.