4

I am trying to get Ubuntu 15.10 dual booted with Windows 10. But the GRUB menu does not show up.

The PC came pre-installed with Windows 8.1 and I upgraded it to Windows 10. Following directions from here, these are the steps I took

  1. Confirmed that windows 10 was booted using UEFI (diskmgmt.msc reports one filesystem in Disk 0 as "EFI System Partition". diskpart.exe indicates a "*" under GPT column).
  2. Downloaded the 64 bit installer and created a FAT-32 formatted live USB (using rufus)
  3. There was no option to disable fast boot in my BIOS. Disabled fast boot in Windows (control panel -> power options -> turn off fast startup) and hibernate option as well
  4. In BIOS settings, disabled legacy-support/BIOS boot and secure boot.
  5. Booted with the live USB and was prompted to try or install ubuntu. I opted to try. BTB, since this menu was presented I understand the live USB was booted in UEFI mode and not BIOS mode.
  6. Created ext4 (/dev/sda6) and swap (/dev/sda9) partitions using gparted (from live USB)
  7. Started Ubuntu install and opted to install beside windows boot manager. Selected "advanced partitioning tool" for partition selection and selected sda6 for root (with formatting and ext4) and sda9 for swap. sda2 (windows' UEFI boot partition) was markd "uefi".
  8. Completed install. Re-booted after removing live USB. The system booted directly into Windows 10.
  9. So I re-booted back into the live USB and ran boot-repair with recommended fixes. This had no impact. As recommended by boot-repair, ran "bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi" in windows successfully. Again no impact. root-repair report is here: http://paste.ubuntu.com/15525648/

Appreciate any pointers on what could be going wrong. TIA.

Update: If I boot with the live USB and press escape in the "Try/Install" menu, the "crub >" CLI is presented and typing "exit" here leads to the GRUB menu and I can select the installed Ubuntu and use it. But would hate to use the live USB everytime I need to boot into Ubuntu.

  • Where is your /boot or /boot/efi partition? – Izzno Mar 27 '16 at 20:31
  • Please see my answer to this question. – Rod Smith Mar 27 '16 at 22:07
  • Thank you @RodSmith. Step 4 in your answer resolved my issue. For posterity, the option is worded "Backup and rename Windows EFI files (solves the [hard-coded-EFI] error)". If you would like to post your comment as an answer, I am happy to accept it. edit: Since I am a newbie here, I cannot up-vote your other answer. :-( – Ram Mar 27 '16 at 23:05
  • 1
    Possible duplicate of boot-repair not working on hp elitebook 2170 – David Foerster May 11 '17 at 18:10
  • have you checked 'Boot devices' list in your BIOS. Maybe you will find ubuntu there. I had this problem after I dual booted Ubuntu. – Jrct Jul 6 '18 at 8:43
0

Where is your /boot/efi partition?

if you disabled legacy mode in BIOS and did not set a /boot/EFI partition in Ubuntu install partition manager you in fact installed lagacy boot. Try enabling legacy boot in BIOS and run boot repair again.

EDIT: If you run legacy mode make sure this is enabled in bios and the order it boots is set to legacy first. You also have to make sure secureboot is off as it sometimes prevents you from altering the MBR. Install bootloader on /dev/sda <---

  • During install, sda2 (windows' boot partition) was marked as "EFI System Partition". boot-repair states "# /boot/efi was on /dev/sda2 during installation". But then it states " /boot/efi added in sda6/fstab". Makes me wonder if boot-repair moved it to sda6. I enabled legacy mode and ran boot repair. The report is at paste.ubuntu.com/15526927. – Ram Mar 27 '16 at 21:33
  • According to your output you installed legacy mode. It also says you have a bootloader on /dev/sdb. You need to install the bootloader on /dev/sda or change the boot order to boot /dev/sdb first in your BIOS. If you can set the Legacy / EFI boot order in your BIOS please try and set Legacy first. – Izzno Mar 27 '16 at 21:44
  • sdb is the live usb device. – Ram Mar 27 '16 at 21:56
  • You still need to install the bootloader on /dev/sda :) – Izzno Mar 27 '16 at 22:28
0

What happened is that windows 10 hard locked your NTFS partition as it does with fake-shutdown/restart.

If your Ubuntu is freshly installed then you may as well run the installation again.

In windows hit Windows then cmd then Shift+Enter, type: powercfg -h off, Enter

Then reboot (to the ubuntu live install USB) and run the install process again.

this time here:

ubuntu installation type

Select "Something else" or "Erase Ubuntu 15.10 and Reinstall". I prefer Something Else as it doesn't attempt to re-use GRUB.

You'll be prompted with this:

gparted partitioning

Delete all ext and swap partitions, create an EFI one if there isn't one already if there is don't create and don't delete it. Add an ext4 partition with mountpoint / and install to that.

good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.