Been trying for various answers to this for a while

Background: I run a partitioned hard drive with Windows XP and Ubuntu. I have important files on both partitions but most of them are on the Ubuntu side.

Problem: interrupted update process from Ubuntu 11.04 (I think it's that one, though might have been a special netbook version) to the new 11.10. result is that I cannot reboot. The screen gets stuck at the startup screen with dots. I cannot access the terminal from here, despite some forum posts suggesting that this should be possible. Same goes for the (recovery mode) option - no joy. This obviously means that I cant access the files in the ubuntu part of the drive.

My approach so far has focused upon accessing the lost files.

I have made a boot USB for Ubuntu 11.10 and successfully booted to it. I hoped that it would allow access to the old files. It doesn't - from what I can tell the files are in a folder that is locked ('permission denied' or something to that effect).

I have tried accessing the files from Windows using Diskinternal's Linux reader and similar programs. These don't seem to work - they provide long lists of files with incomprehensible names which cant be opened.

The one thing I haven't tried is running the main install option for 11.10 from the USB booted desktop. I'm worried that it would erase the files I'm trying to retrieve. Any thoughts there?

I realize that the main avenue I haven't looked at is to try to fix the corrupted 11.04 version of ubuntu. However I have almost no experience of using the terminal and am a complete newbie in this respect. I can enter commands directly from something I'm given but cant problem solve myself - just have no idea what I'm doing. If I was to take this approach I'd need my hand held the whole way.

So, can anyone help me here? Would be hugely appreciative!


Did you make a partition for your /home directory or did you by chance encrypt your home folder when you installed linux? Cause normally with a live cd you'd be able to mount your linux partition (like a usb drive) and search the filesystem on it. So it shouldn't be a problem to copy files out of the /home folder

  • Ahh... you might have hit upon something there. I was not the one who set up linux on this machine. A techie friend of mine introduced me to linux last year and did the whole business, including all the partitioning. He works in internet security so encrypting the home folder is the sort of thing he'd do. Unfortunately he's now overseas. Anyway, if it is encrypted how would that change the situation? I guess that might also explain why using DiskInternal from Windows is turning up a load of nonsense. – Andrew Nov 3 '11 at 9:11
  • You'd need to know the password to decrypt it...I've actually never encrypted my home folder but I guess it's just the same password you used to log into your machine. However I'm not sure where you have to put it...I'm gonna try this really quick in a virtual machine – Daniel W. Nov 3 '11 at 9:36
  • Ahhh much better...the forums provide wisdom for that kind of problem...here's the link: ubuntuforums.org/showthread.php?t=1597246 – Daniel W. Nov 3 '11 at 9:49

First idea:

You can boot again using the USB bar after that you invoke

sudo chroot /media/whatever /bin/bash -i

replace /media/whatever with the mount location of your root partition of the broken system. With that you are now working in the environment of your broken system and can copy files and fix things, etc.

ANother idea: If you use grub as Bootmanager you can also try to boot into command line only mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.