After installing Ubuntu Mate, Rhythmbox not importing mp3 files from music folder. and when I tried to play mp3 files, It wont play.


To play mp3 files with Rhythmbox you need the gstreamer 'ugly' plugins. There are 3 good choices to getting these installed and running with Rhythmbox;

1. This should be shown when you try to open such a file:

enter image description here

Simply install from here and Rhythmbox will happily play your mp3s.

2. If the menu does not appear you can install install from the commandline (on Trusty Tahr):

sudo apt-get install gstreamer1.0-plugins-ugly

And hopefully this will be enough to get your mp3s playing.

3. If not the final choice is to get the latest and greatest Rhythmbox with the annoying 'can't see mp3s/plugins properly' bug ironed out:

sudo add-apt-repository ppa:fossfreedom/rhythmbox
sudo apt-get update
sudo apt-get install rhythmbox gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gnome-control-center rhythmbox-plugin-visualizer

And then all should be well...

  • well it is not showing anything like that. please can you tell me how to update via terminal.thanks – T. Gardi Mar 27 '16 at 5:39
  • 1
    sudo apt-get install gstreamer1.0-plugins-ugly should be enough... – andrew.46 Mar 27 '16 at 6:10
  • I'll try that. by the way can you please tell me how to save terminal after edit grub. I cannot find anywhere a "Save" option.thanks. – T. Gardi Mar 27 '16 at 9:16
  • I did exacty what you told.still not working. it is not playing,not importing music,opening the player in mute, cannot drag and drop music files and when press start button it display ''couldn't start playback (null)'' error massage – T. Gardi Mar 28 '16 at 4:08
  • Hopefully somebody more clever than myself can help out then, sorry.... – andrew.46 Mar 28 '16 at 4:33

If you have tried the solutions on this page and STILL can not get your .mp3 files to play in Rhythmbox, try this:

  1. Open Terminal
  2. Enter the following:

    sudo chmod 777 path/to/YourJamz

    2a. Lazy Person Tip: After entering sudo chmod 777 in the terminal, Open Nautilus, find your music files and drag them into the terminal. Terminal will automatically display the /path/to/your/files/for/you/ for you.

  3. Press Enter

  4. Close Terminal.

  5. Open Rhythmbox; your files should be visible/able to be played.

    5a. Alternately, open Nautilus, right click your file, select "open with Rhythmbox"; your .mp3 file should now be playing with Rhythmbox.

This worked for me, I hoped it helped. Good luck, and happy breakdancing!

  • I want to say that the only that worked for me was to chmod using the octal format. chmod 0777 /path/*p. That seems to happen when you copy music from a zipped file or other media not yours. Thx. – m3nda Jan 30 '17 at 19:18

Because the ethos of Linux is that all software should be free in terms of Liberty and usually but not necessarily cost. There is some software that does not get installed by default.

One example is mp3 which is a propriety format and someone has had to pay a licence fee and sign an NDA (Non Disclosure Agreement) in order get access to to details so that mp3 files can be decoded. Because of this it is not possible to make this software open source.

In earlier versions of Ubuntu this made things awkward as you had find and install these your self. However, in more recent versions you are now asked if you want these propriety, non open source, programs installed when you install. If you didn't say yes during installation you can find them in the software centre under restricted-extras.

  • However, happily, the patents are expiring either April 2017 or March 2020. – user423626 Mar 26 '16 at 16:35

I tried the stated solutions but nothing worked. What worked was when I went into the virtual box settings under Audio and started going between the different settings.

enter image description here

Once I did this, and probably in combination of the other stated solutions in which you do in Ubuntu itself, I was finally able to listen to and play my MP3 files.

  • How is that related to the question, rythmbox and mp3 libs? – m3nda Jan 30 '17 at 19:15
  • He's running Ubuntu in Virtualbox, on an other operating system. Apparently, in the context of the question, the extra layer Virtualbox presents can be an extra hurdle. – Levente Jan 25 at 17:52

For those that the plugin list and/or installing ugly package didn't work, like me.

I want to say that the only that worked for me was to chmod using the octal format. chmod 0777 /path/*p. Doing that allowed me to ONLY play files, but not to add mp3 files to library.

So, i went to preferences and tried with no lucky the option "prefer mp3 files" and used the bottom buttom "install xxx libs", which returned nothing, but a bug (https://bugs.launchpad.net/ubuntu/+source/gnome-codec-install/+bug/888847).

Finally, installing apt-get install -y gstreamer1.0-plugins-bad package make it fully work and be able to add mp3 to lib.



List of candidates:

sudo apt-get install -y           \
    libgstreamer1.0-0             \
    gstreamer1.0-plugins-base     \
    gstreamer1.0-plugins-good     \
    gstreamer1.0-plugins-bad      \
    gstreamer1.0-plugins-ugly     \
    gstreamer1.0-libav            \
    gstreamer1.0-doc              \
    gstreamer1.0-tools            \
    gstreamer1.0-x                \
    gstreamer1.0-alsa             \
    gstreamer1.0-gl               \
    gstreamer1.0-gtk3             \
    gstreamer1.0-qt5              \

Checking out what is already installed...

apt list --installed | grep gstream

In case of a fresh Ubuntu MATE 20.04 (Focal Fossa) all it took was:

sudo apt-get install -y gstreamer1.0-plugins-bad

(this: not “ugly”, “bad” :-)

  • 1
    When suggesting installing gstreamer1.0-plugins-bad it's worth mentioning that they might pose a security risk. It's not a coincidence they are called bad. Proceed at your own judgement. – Levente Jan 25 at 17:58
  • From the package's own description: "GStreamer Bad Plug-ins is a set of plug-ins that aren't up to par compared to the rest. They might be close to being good quality, but they're missing something - be it a good code review, some documentation, a set of tests, a real live maintainer, or some actual wide use." – Levente Jan 25 at 18:27
  • @Levente - do I have an alternative (when I want mp3 encoding support)? (other than doing the encoding outside rhythmbox und only playback here) – Frank Nocke Jan 26 at 9:10
  • 1
    I have only gstreamer1.0-plugins-good and the gstreamer1.0-plugins-ugly installed, and Rythmbox does play mp3's. – Levente Jan 26 at 13:15

Did you select the Install this third-party software option in the installer? That software enables playback of restricted, proprietary formats like FLV, MP4 and MP3.

If not, install Ubuntu Restricted Extras from the Software Center.

  • I did intall Restricted extras. but problem still exists. any ideas please. – T. Gardi Mar 27 '16 at 1:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.