1

in ubuntu 14.10 when i try to install cassandra with this command "apt-get install cassandra " i have the following errors :

edit bodhi.zazen - translation from M.Info

Reading package lists ... Done

Shaft Construction dependencies

Reading state information ... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or are not out of Incoming. The following information should help you resolve the situation:

The following packages have unmet dependencies: Cassandra: Depends: python-support (> = 0.90.0) but it is not installable Recommends: ntp but will not be installed or time-daemon but it is not installable

E: Unable to correct problems, defective packets are "keep state" mode.

and when i try to update :

W: Unable to recover http://ppa.launchpad.net/andrei-pozolotin/maven3/ubuntu/dists/utopic/main/binary-i386/Packages 404 Not Found

W: Unable to recover http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/utopic/main/binary-i386/Packages 404 Not Found

E: The download some index files failed, they have been ignored, or old were used instead.

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait Certains paquets ne peuvent être installés. Ceci peut signifier que vous avez demandé l'impossible, ou bien, si vous utilisez la distribution unstable, que certains paquets n'ont pas encore été créés ou ne sont pas sortis d'Incoming. L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites : cassandra : Dépend: python-support (>= 0.90.0) mais il n'est pas installable Recommande: ntp mais ne sera pas installé ou time-daemon mais il n'est pas installable E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ». i think that the problem is when i try to update with "apt-get update" because i have : W: Impossible de récupérer http://ppa.launchpad.net/andrei-pozolotin/maven3/ubuntu/dists/utopic/main/binary-i386/Packages 404 Not Found

W: Impossible de récupérer http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/utopic/main/binary-i386/Packages 404 Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place. help me pleeeese

closed as off-topic by Panther, Pilot6, David Foerster, Eric Carvalho, Luís de Sousa Apr 8 '16 at 12:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

2

Basically those errors are due to missing dependencies.

If you look at the ppa in question - https://launchpad.net/~andrei-pozolotin/+archive/ubuntu/maven3 - you will see that there are no packages available for utopic

http://ppa.launchpad.net/andrei-pozolotin/maven3/ubuntu/dists/

Thus you are getting a 404 error when trying to install maven.

I am not really familiar with maven or cassandra.

Your options are :

  1. Find another ppa for maven that has packages for utopic

  2. Build maven (and dependencies) from source code.

Really, the main problem you have is 14.10 is beyond end of life and you should really upgrade or install a supported version of Ubuntu

  • thank you ,but I have already installed the Apache Maven 3.2.5 – M.Info Mar 26 '16 at 14:40
  • @M.Info - I understand, but, you are on a version of ubuntu that is no longer supported and you are referring to a non-existant ppa, that is the cause of your problem, not the version of Apache Maven you have installed, lol – Panther Mar 26 '16 at 19:41
  • so I have no hope for this version !! :( – M.Info Mar 26 '16 at 19:47
  • @M.Info- your version of Ubuntu is beyond end of life - ubuntu.com/info/release-end-of-life " When an Ubuntu release reaches its “end of life” it receives no further maintenance updates, including critical security upgrades. We highly recommend that you upgrade to a recent version of Ubuntu at this point." so yes, you are on your own. Worse you are running servers on a n OS that receives no security updates. So while it is possible for you to continue on 14.10 it will be difficult, insecure, self maintained, and ill advised. Please upgrade or install a supported version of ubuntu. – Panther Mar 27 '16 at 13:15
0

I am huge fan of DataStax Cassandra and it works very well on the Ubuntu 14.04 LTS(they support LTS releases). Datastax Enterprise Cassandra is available free of cost for personal use But in your case you are on 14.10 and it won't work unless you reinstall/downgrade 14.04LTS.

My advise is to get on to Ubuntu Linux 14.04 LTS version and install DataStax Enterprise Cassandra. Installation is piece of cake and it's very stable. You can just download the install-able(DataStaxEnterprise-4.8.5.2016022818-linux-x64-installer.run) from https://academy.datastax.com/downloads/welcome

But you can follow this: This works with Oracle Java 8 or OpenJDK 8

Add the DataStax Distribution of Apache Cassandra 3.2 repository to the /etc/apt/sources.list.d/cassandra.sources.list

$ echo "deb http://debian.datastax.com/datastax-ddc 3.2 main" | sudo tee -a /etc/apt/sources.list.d/cassandra.sources.list

Add the key

curl -L https://debian.datastax.com/debian/repo_key | sudo apt-key add -

sudo apt-get update
sudo apt-get install datastax-ddc

in case the service is not starting up perform this

sudo service cassandra start

For more information, please refer to this or this one

  • thanks a lot , but when i do " sudo apt-get install datastax-ddc" i have the same error i think that the problem is in ' sudo apt-get install' – M.Info Mar 26 '16 at 18:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.