0

I'm trying to get up a gui on my Ubuntu server (14.04), but failing despite trying some different things.

What I'm seeing: Machine boots to blank screen with a cursor (arrow) in the middle. I can move the cursor.

What I did after clean install:

# install, boot to command line, log in
sudo apt-get update
sudo apt-get upgrade
dist-upgrade
sudo reboot # so os can boot with new kernel
sudo nano /etc/default/grub 
# set GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
sudo apt-get install --no-install-recommends lubuntu-desktop
sudo nano /etc/lightdm/lightdm.conf
## put the following
# [SeatDefaults]
# greeter-session=lightdm-gtk-greeter
# user-session=Lubuntu
sudo reboot

At this point the login screen should appear, but it doesn't. From here, I tried to do this, as suggested here How to fix blank screen with mouse pointer on Ubuntu install reboot?

sudo apt-get purge lightdm
sudo apt-get update
sudo apt-get install lightdm
dpkg-reconfigure lightdm

Now upon reboot, there is a slight change: there seems to be something 'underneath' the blank screen, since at some areas of the screen the cursor symbol changes form arrow to a text cursor (looks like a T with another line underneath)

I also tried to reinstall lubuntu, but with no effect.

How can I get up my login screen?

0

open Terminal using ctrl+alt+F3 and login type ls and you'll see a file in your home called .Xauthority replace it using this command

mv .Xauthority .Xauthority1 then reboot tell us if it works

  • it seems to have no effect – user523210 Mar 26 '16 at 13:30
0

The problem disappeared when I reinstalled the OS on a 3.0 USB stick (32GB) instead of on the initial 2.0 stick (16GB). I followed the exact same routine as before, only difference was the USB. I still don't know what exactly the problem was, just that this solved it for some reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.