2

apt-get always fails when I try anything. I can't install, remove, update, upgrade and even dist-upgrade. When I try sudo apt-get update I got this message :

E: Some index files failed to download. They have been ignored, or old ones used instead.

apt-get install

E: Unmet dependencies.

apt-get upgrade :

The following packages have unmet dependencies:  libc-dev-bin :
 nullDepends:  libc6 (> 2.22) but 2.19-0ubuntu6.6 is installed  libc-l10n :
 nullBreaks: locales (< 2.21-1)  libc6-dbg : Depends: libc6 (= 2.22-3) but
2.19-0ubuntu6.6 is installed  libc6-dev : Depends: libc6 (= 2.22-3) but 2.19-0ubuntu6.6 is installed  libc6-i386 : Depends: libc6 (=
2.22-3) but 2.19-0ubuntu6.6 is installed  plymouth : Depends: init-system-helpers (>= 1.18) but 1.14 is installed  plymouth-label :
 nullDepends: plymouth (= 0.8.8-0ubuntu17.1) but 0.9.2-3 is installed W:
 nullIgnoring Provides line with DepCompareOp for package libjpeg62 W:
 nullIgnoring Provides line with DepCompareOp for package
 nullphp-psr-http-message-implementation W: Ignoring Provides line with
 nullDepCompareOp for package php-psr-log-implementation W: Ignoring
 nullProvides line with DepCompareOp for package php-seclib W: Ignoring
 nullProvides line with DepCompareOp for package php-sabre-http W: Ignoring
 nullProvides line with DepCompareOp for package php-math-biginteger W:
 nullIgnoring Provides line with DepCompareOp for package pypy-cffi W:
 nullIgnoring Provides line with DepCompareOp for package
 nullpypy-cffi-backend-api-max W: Ignoring Provides line with DepCompareOp
 nullfor package pypy-cffi-backend-api-min W: Ignoring Provides line with
 nullDepCompareOp for package python-cffi-backend-api-max W: Ignoring
 nullProvides line with DepCompareOp for package
 nullpython-cffi-backend-api-min W: Ignoring Provides line with
 nullDepCompareOp for package python3-cffi-backend-api-max W: Ignoring
 nullProvides line with DepCompareOp for package
 nullpython3-cffi-backend-api-min W: Ignoring Provides line with
 nullDepCompareOp for package libjpeg62 W: Ignoring Provides line with
 nullDepCompareOp for package python-cffi-backend-api-max W: Ignoring
 nullProvides line with DepCompareOp for package
 nullpython-cffi-backend-api-min W: Ignoring Provides line with
 nullDepCompareOp for package python3-cffi-backend-api-max W: Ignoring
 nullProvides line with DepCompareOp for package
 nullpython3-cffi-backend-api-min W: You may want to run apt-get update to
 nullcorrect these problems E: Unmet dependencies. Try using -f.
  • 1
    Did you try sudo apt-get install -f like it says in the error? – Mark Kirby Mar 26 '16 at 12:32
1

Open software and updates other software tab Untick any repository you dont think should be their like if wine is still their even after you uninstalled it or you dont need the repo (be careful dont delete just untick ,just in case you need it again for some software again sometime in future) close it ,it will ask for refresh cancel it

sudo apt-get update

sudo apt-get install  -f

sudo apt-get dist-upgrade

you can comment out repositorys in terminal also just edit the file

sudo vim /etc/apt/sources.list

and comment the repos you don't need

| improve this answer | |
  • It is impossible for me to even open software and updates whenever I try to I got the "System problem detected" message – Houssem BenHassen Mar 26 '16 at 11:50
  • same can be done by just editing a file i mentioned in the edited question – Shantanu Bedajna Mar 26 '16 at 15:01
0

Apt-get is an available package in the App Store for Ubuntu (pre-installed on normal cases)

You can also download other various package managers available. Apt-get is simply a package manager used to download packages and their dependencies. There are many you can use.

Edit: I recommend also downloading synpack - a package manager in GUI form just in case this ever happens again.

| improve this answer | |
  • I already made a quick search for the best package manager and it seems to be aptitude the problem is I must use the "apt-get install" command to install it. I could not find the .deb package avialable for download immediately – Houssem BenHassen Mar 26 '16 at 11:15
0

In your /etc/apt/sources.list file, the line should look like:

deb http://archive.canonical.com/ubuntu trusty partner

It will not work if the formatting is wrong for the $(lsb_release -sc) part.

| improve this answer | |
  • Could you explain more please – Houssem BenHassen Mar 26 '16 at 11:48
  • @HoussemBenHassen did it work? – Dominic Motuka Mar 26 '16 at 12:52
  • @HoussemBenHassenAs part of its operation, Apt uses a file that lists the 'sources' from which packages can be obtained. This file is /etc/apt/sources.list. The entries in this file normally follow this format deb http://site.example.com/debian distribution component1 component2 component3 and deb-src http://site.example.com/debian distribution component1 component2 component3 – Dominic Motuka Mar 26 '16 at 12:53
  • here are some entries from my sources.list file deb mirrorservice.org/sites/archive.ubuntu.com/ubuntu trusty-backports main restricted universe multiverse deb-src mirrorservice.org/sites/archive.ubuntu.com/ubuntu trusty-backports main restricted universe multiverse – Houssem BenHassen Mar 26 '16 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.