0

In the default configuration of phpmyadmin with ISPconfig-3 on Ubuntu. Strange thing happens, "Order Deny,Allow" & "Deny from All" works for sub-directories (blocks all requests) but not for the root of them.

/usr/share/phpmyadmin (Not working)

/usr/share/phpmyadmin/setup (working)

/usr/share/phpmyadmin/libraries (working)

/usr/share/phpmyadmin/setup/lib (working)

Can you explain this behavior? Do i miss something?

Of course I'm not going to block it at all but when it fails to bock all IPs except mine I tried to test blocking all but it fails!

Note: Ubuntu version 12.04.5 LTS

Here is the /etc/apache2/conf.d/phpmyadmin.conf

# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
        Options FollowSymLinks
        DirectoryIndex index.php

        ......
        Order Deny,Allow
        Deny from All

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
    Order Deny,Allow
    Deny from All

    .......
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
    Order Deny,Allow
    Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
    Order Deny,Allow
    Deny from All
</Directory>
0

I figured it out there is a configuration duplication. The main configuration file of PhpMyAdmin package (/etc/apache2/conf.d/phpmyadmin.conf) configure the directory "/usr/share/phpmyadmin", and ISPConfig re-configured it again in "/etc/apache2/sites-available/ispconfig.conf"! Honestly I didn't expect this duplication but I choose to disable the one in "/etc/apache2/sites-available/ispconfig.conf" and restriction now works.

ISPConfig is great but I think developers should consider this small issue and alike.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.