1

I´m currently unable to make special characters using left alt on my MacBook Pro, Swedish keyboard (running for an external SSD, Ubuntu 14.04).

For example, if i try to make a pair of curly brackets using left alt, i.e. shift+left alt+8 and 9 nothing happens - it only works using right alt. However, left alt do work with other keyboard shortcuts like ctrl+left alt+T. I have tried different keyboard layouts and to look for suitable options in system preferences -> text entry. I did notice that there are similar questions to mine, but they involve special characters using left ctrlleft alt, and not left shiftleft alt. Is it a simple fix to this?

Thank you!

0

Characters as {} [] ~ @ ² ³ µ are not selected by the control+7 key combination (i.e. the { char) but by control+alt+7. The right key on PC/AT keyboard has a special meaning, it is the same as pressing left alt+ctrl keys - that is why it is inscriped AltGr.

So for my understanding it is all fine with your keyboard.

| improve this answer | |
0

This is what I had to do (Taken from this answer):

sudo dpkg-reconfigure keyboard-configuration

  • Choose the 104-key layout (thanks to this answer)
  • Use the default options for the rest

sudo service keyboard-setup restart

And that was it! Now my keyboard's alt + shift combination works again! More specifically, the ones on the left of the keyboard.


In case you were curious, my laptop is a Lenovo G510, and I am running Ubuntu 16.04 at the time of writing this answer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.