0

This question already has an answer here:

I am using latest Ubuntu version. I'm having 64-bit system. When I run sudo apt-get update I get the below errors at the end of the result.

...
Get:79 http://us.archive.ubuntu.com precise/universe Translation-en [3,341 kB] 
Get:80 http://us.archive.ubuntu.com precise-security/main i386 Packages [848 kB]
Ign http://us.archive.ubuntu.com precise/main Translation-en_IN                
Ign http://us.archive.ubuntu.com precise/multiverse Translation-en_IN          
Ign http://us.archive.ubuntu.com precise/restricted Translation-en_IN          
Ign http://us.archive.ubuntu.com precise/universe Translation-en_IN            
Fetched 30.0 MB in 13min 1s (38.4 kB/s)  
W: GPG error: http://extras.ubuntu.com precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192
W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

I am not able to find the mistake I am making.
I am not familiar with this command line. Please someone help me rectifying this.

thanks

marked as duplicate by kos, Eric Carvalho, David Foerster, Pilot6, muru Mar 26 '16 at 14:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Seems you are using Precise Pangolin (12.04 LTS) repository, what Ubuntu version you are in? – Arijit Chatterjee Mar 25 '16 at 8:03
  • @ArijitChatterjee Ubuntu 15.10 – Gopi Mar 25 '16 at 8:50
  • 1
    @Gopi: ArijitChatterjee is right. You are updating from 12.04 repository not 15.10. But I dont think this be responsible for the current problem – Mostafa Ahangarha Mar 25 '16 at 9:27
0

Regarding the error message, you are facing with two separate problems.

GPG error:

For solving public key problem, run this command:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys <PUBKEY>

in which you should replace with the mentioned public key in the error message which is: 16126D3A3E5C1192.

Google Chrome Source List

This problem, as it is well explained in this answer. For more detail, read the answer.
Meanwhile, since you are using 64-bit system, you can use 64-bit Chrome. So force it to just get updates for 64-bit by running this command:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list" "/opt/google/chrome/cron/google-chrome"

Ubuntu Version

You said you are using latest version of Ubuntu (which should be Wily 15.10). But as it is apparent in the result of the command, you are getting updates for Ubuntu Precise Pangolin (12.04 LTS)

How is this possible?

  • Comments are not for extended discussion; this conversation has been moved to chat. – Mitch Mar 26 '16 at 10:22
0
  1. Open a new Terminal window and run the following command:

sudo gedit /etc/apt/sources.list.d/google-chrome.list

  1. In the text file that opens edit the file so that the line reads:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

The only addition you need to make is entering the [amd64] architecture after ‘deb’ but preceding the ‘http’. Do not edit or replace any other text in this file.

  1. Hit Save. Close the Gedit window.

Now return to the Terminal and refresh your package list by running:

sudo apt-get update The ‘failed to fetch’ APT error should no longer appear.


source

  • This in the best, will only solve Google Chrome problem, which I have already mentioned the solution – Mostafa Ahangarha Mar 25 '16 at 9:39
  • @Mohamedyix ### THIS FILE IS AUTOMATICALLY CONFIGURED ### # You may comment out this entry, but any other modifications may be lost. deb [arch=amd64] dl.google.com/linux/chrome/deb stable main this is how it looked after the step one where should i chge to amd 64 in here – Gopi Mar 25 '16 at 9:42
  • Then you don't need to change anything! this is the solution for the "google chrome" part of your error \ try the above solution of Mostafa for the "GPG" error – mohamedyix Mar 25 '16 at 9:45
  • @mohamedyix but now i am facing new problem which i have comment in Mostafa Ahangarha do you know you – Gopi Mar 25 '16 at 9:47
  • does your file look exactly like this picture? – mohamedyix Mar 25 '16 at 9:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.