1

I want to uninstall virtual box from my system. I run following command:

sudo apt-get remove virtualbox* --purge

The result says it is uninstalled. But I could still launch the virtual box. Please let me know what needs to be done. Thanks

0

It sounds like you installed VirtualBox from an installer file instead of from an apt repository--possibly in addition to installing from an apt repository (the latter you seem to have already removed, if it existed). If the VirtualBox version is 2.2.2 or later, you can do this:

sudo /opt/VirtualBox/uninstall.sh

If it's an earlier version (2.2.1 or earlier), you need to find the installer file you downloaded (or re-download it) and run this from the same directory as that file:

./VirtualBox.run uninstall

If you can't find the appropriate installer file for a version 2.2.1 or earlier, then you need to remove all the files, manually. To do this, perform the "manual installation" steps in reverse order, deleting files instead of creating/moving/copying them, deleting symlinks instead of creating them, removing edits to configuration files, etc.:

https://www.virtualbox.org/manual/ch02.html#idp46457698198016

  • Thanks. I manually removed the files and reinstalled the updated virtual box and it worked. – Aditya V Mar 25 '16 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.