I tried to reinstall Ubuntu Touch to my BQ Aquaris E4.5 but something went wrong. I followed these steps: https://developer.ubuntu.com/en/start/ubuntu-for-devices/installing-ubuntu-for-devices/ .

Everything was fine until the last step. My phone just showed no reaction. I tried to do a full reset through recovery mode, but afterwards i was stuck in a bootloop. Now my PC does not recognize my phone anymore, the recovery mode isn't working (phone just restarts) and if i go in to fastboot mode it is displayed in the console (fastboot devices) but if i try to do something nothing ever happens. It's not even possible to turn the device of. It's just rebooting all the time (it boots to the 'bq'-logo then the screen goes of, it vibrates and reboots again).

So i waited like 6 hours until it runs out of battery but this didn't helped neither.

What can i do to come back to Android or Ubuntu? I don't care about my data. Just want my phone to work again :s

EDIT: OK it lokks like i can reach my phone now through 'ubuntu-device-flash' and 'fastboot'

but if i try

ubuntu-device-flash touch  --channel=ubuntu-touch/stable/bq-aquaris.en --bootstrap --device krillin

i always get

Cache formatting was not successful, flashing may fail, check your partitions on device
Can't boot recovery image

any idea how i can get rid of this?


i tried it with the recovery image from https://wiki.ubuntu.com/Touch/Devices#Working_with_ubuntu-device-flash:

ubuntu-device-flash touch  --channel=ubuntu-touch/stable/bq-aquaris.en --bootstrap --device krillin --recovery-image=/home/berry/Downloads/recovery-krillin.img
2016/03/25 15:10:18 Device is |krillin|
2016/03/25 15:10:19 Flashing version 30 from ubuntu-touch/stable/bq-aquaris.en channel and server https://system-image.ubuntu.com to device krillin
3.61 MB / 68.50 MB [=====>____________________________________________________________________________________________________________________________] 5.27 % 839.37 KB/s 1m19s2016/03/25 15:10:23 Cache formatting was not successful, flashing may fail, check your partitions on device
3.91 MB / 68.50 MB [======>___________________________________________________________________________________________________________________________] 5.70 % 799.39 KB/s 1m22sCan't boot recovery image
  • If your device was a retail Android device from BQ, you will need to follow the instructions from BQ with additional tools provided by them, to repartition your phone so that Ubuntu can be installed on it. – dobey Mar 25 '16 at 2:33
  • My device was an Ubuntu Edition but i switched to Android for a while and now i wanted to switch back. On BQs webside there is only this 'MediaTek flash tool' which isn't working for me because it can't find any connection to my device – Enamrov Enamchan Mar 25 '16 at 12:12
  • i can 'see' the device in fastboot mode with "fastboot devices" and it looks like i can do something now. So i tried to format or erase the cache but i always get this error message: ' fastboot erase data erasing 'data'... FAILED (remote: unknown command) finished. total time: 0.002s' why is the command unknown? – Enamrov Enamchan Mar 25 '16 at 12:29

You need the recovery-krillin.img file linked on the Devices wiki page, in order to re-flash the factory E4.5. You then need to run the same ubuntu-device-flash command you are currently running with the --recovery-image=recovery-krillin.img argument appended.

  • this did not woked: I get two errors: "Cache formatting was not successful, flashing may fail, check your partitions on device" and "Can't boot recovery image" – Enamrov Enamchan Mar 25 '16 at 14:17
  • Then it would probably be best to contact BQ support. It sounds like the flash may be damaged, or you've managed to do something to break the partitioning on the device. – dobey Mar 25 '16 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.