0

So I was running Ubuntu 12.10 until today I decided to upgrade since it is no longer supported. Now all of a sudden my Ethernet connection doesn't work and my computer is useless. In the top right corner of the screen the symbol looks as if the computer is searching for a wireless network. Also if it keeps telling me every couple of seconds that I was disconnected from the Internet and if I go to edit connected it always says the Ethernet was used just a couple of minutes ago. I'm not all that computer savvy so idk where to begin. Any help would be really appreciated. Thanks

Ifconfig gives me...damn I gotta type this by hand on a cell phone...

Eth0 link encap:Ethernet HWaddr 00:1b:b9:54:17:e1 Inet6 addr: fe80::21b:b9ff:fe54:17e1/64 Scope:Link UPBROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets: 0 errors:0 dropped:0 overruns:0 frame:0 TX packets:247 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:47544 (47.5 KB)

lo Link encap:Local Loopback Inet addr:127.0.0.1 Mask:255.0.0.0 Inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:153 errors:0 dropped:0 overruns:0 frame:0 TX packets:153 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:10928 (10.9KB) TX bytes:10928 (10.9KB)

Ping -c 4 8.8.8.8 gives me...

Connect: Network is unreachable

And ping -c 4 Google.com reads...

Ping: Unknown host Google.com

And finally cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

Auto lo Iface lo inet Loopback

Any ideas anyone? Really need to get my computer working thanks for the help

  • Begin by editing your post to include the output of ifconfig and ping -c 4 8.8.8.8 and ping -c 4 google.com. The output of cat /etc/network/interfaces might also be useful. – Gasp0de Mar 24 '16 at 14:35
0

I would try:

sudo dhclient -v eth0

it seems your link is up but you do not have ip address.

  • That's giving me listening on LPF/eth0/00:1b:b9:54:17:e1 Sending on LPF/eth0/00:1b:b9:54:17:e1 Sending on socket/fallback DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3 (xid=0x7ad3040b) And that just keeps repeating at intervals and finally it says No DHCPOFFERS RECEIVED No working leases in persistent database - sleeping. – Forrest Pangle Mar 24 '16 at 15:43
  • Just went to the store and came back and all of a sudden everything is working fine...scared to restart the computer or anything cas I feel like it's gonna happen again – Forrest Pangle Mar 24 '16 at 16:13
  • Never mind didn't even have to restart the computer it just stopped working on its own – Forrest Pangle Mar 24 '16 at 16:23
  • Managed to grab this info while it was working though, is there a way to manually configure the connection using any of this? IP address: 192.168.0.13 Broadcast address: 192.168.0.255 Subnet mask: 255.255.255.0 Default route: 192.168.0.1 Primary DNS: 209.18.47.61 Secondary DNS: 209.18.47.62 – Forrest Pangle Mar 24 '16 at 16:38
  • you can add that info to /etc/network/interfaces, but it is odd that it is not working via dhcp. If you want to give it a try, sudo service networking stop and add this to the file mentioned earlier: auto eth0 iface eth0 inet static address 192.168.0.13 netmask 255.255.255.0 network 192.168.0.0 broadcast 192.168.0.255 gateway 192.168.0.1 You can see the interfaces file formatted correctly in this link [ www.cyberciti.biz/faq/setting-up-an-network-interfaces-file/]. Then save,exit and execute sudo service networking start. – S.Ith Mar 24 '16 at 17:10
0

So when I put the newer version of Linux on here earlier today it automatically made a connection called connection 1 or something like that and anyhow all I did was delete it and then click "auto Ethernet" and it works perfectly now...odd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.