0

I have Ubuntu 14.04 LTS (64-bit), but can't install Wine. All I get is broken dependencies.

Tried all in my mind...

sudo apt-get update  && upgrade  and even with dist-upgrade
sudo apt-get autoclean
sudo apt-get install -f
sudo dpkg --configure -a

I've checked in the dpkg status file (/var/lib/dpkg/status/) after anything broken, but couldn't find anything.

What to do?

Q4wine worked, but not wine?

This happens when I try to install wine:

sudo apt-get install wine

[My text is in swedish...]
Basically saying; Dependent on wine1.6


When I try to install wine1.6; sudo apt-get install wine1.6 ...dependent on wine1.6-i386


When I try to install wine1.6-386; sudo apt-get install wine1.6-i386


... wine1.6-i386:i386 : Beroende av: libglu1-mesa:i386 men det kommer inte att installeras eller
                                  libglu1:i386
                     Beroende av: libgphoto2-6:i386 (>= 2.5.2) men det kommer inte att installeras
                     Beroende av: libgphoto2-port10:i386 (>= 2.5.2) men det kommer inte att installeras
                     Beroende av: liblcms2-2:i386 (>= 2.2+git20110628) men det kommer inte att installeras
                     Rekommenderar: libsane:i386 men det kommer inte att installeras

I added support for i386 architecture doing as proposed below, but it did not change or help anything.

But when I tried aptitude instead of apt-get, I got a little longer:

I got a lot of options of fixing the dependencies issues, with a question of y/n/q. But when answered y, it does not start install, only goes back to prompt with info "nothing installed".


This is the output I am getting;

cai@caiThink:~$ sudo aptitude install wine

[sudo] password for cai:

The following NEW packages will be installed: fonts-horai-umefont{a} libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a} libasyncns0:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a} libavahi-common3:i386{a} libcapi20-3{a} libcapi20-3:i386{a} libcgmanager0:i386{ab} libcups2:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a} libelf1:i386{a} libexif12:i386{a} libexpat1:i386{a} libffi6:i386{a} libflac8:i386{a} libfontconfig1:i386{a} libfreetype6:i386{a} libgcrypt11:i386{a} libgd3:i386{a} libgif4:i386{a} libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a} libglib2.0-0:i386{a} libglu1-mesa:i386{a} libgnutls26:i386{a} libgpg-error0:i386{a} libgphoto2-6:i386{a} libgphoto2-port10:i386{a} libgssapi-krb5-2:i386{a} libgssapi3-heimdal:i386{a} libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} libice6:i386{a} libieee1284-3:i386{a} libjack-jackd2-0:i386{a} libjbig0:i386{a} libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a} libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a} libkrb5support0:i386{a} liblcms2-2:i386{ab} libldap-2.4-2:i386{a} libllvm3.4:i386{a} libltdl7:i386{a} libmpg123-0:i386{a} libogg0:i386{a} libopenal1:i386{a} liborc-0.4-0:i386{a} libosmesa6:i386{a} libp11-kit-gnome-keyring:i386{a} libp11-kit0:i386{a} libpciaccess0:i386{a} libpulse0:i386{a} libroken18-heimdal:i386{a} libsamplerate0:i386{a} libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libsm6:i386{a} libsndfile1:i386{a} libspeexdsp1:i386{a} libsqlite3-0:i386{a} libssl1.0.0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a} libtxc-dxtn-s2tc0:i386{a} libudev1:i386{a} libusb-1.0-0:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} libvorbis0a:i386{a} libvorbisenc2:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{a} libwrap0:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a} libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxi6:i386{a} libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a} libxrender1:i386{a} libxshmfence1:i386{a} libxslt1.1:i386{a} libxt6:i386{a} libxxf86vm1:i386{a} ocl-icd-libopencl1:i386{a} p11-kit-modules:i386{a} p7zip{a} unixodbc{a} wine wine-gecko2.21{a} wine-gecko2.21:i386{a} wine-mono0.0.8{a} wine1.6{a} wine1.6-amd64{a} wine1.6-i386:i386{a} winetricks{a}

0 packages upgraded, 126 newly installed, 0 to remove and 0 not upgraded. Need to get 155 MB of archives. After unpacking 546 MB will be used. The following packages have unmet dependencies:

liblcms2-2 : Breaks: liblcms2-2:i386 (!= 2.6-3ubuntu1~trusty1) but 2.5-0ubuntu4 is to be installed. liblcms2-2:i386 : Breaks: liblcms2-2 (!= 2.5-0ubuntu4) but 2.6-3ubuntu1~trusty1 is installed. libcgmanager0 : Breaks: libcgmanager0:i386 (!= 0.39-2ubuntu2~ubuntu14.04.1) but 0.24-0ubuntu7.5 is to be installed. libcgmanager0:i386 : Breaks: libcgmanager0 (!= 0.24-0ubuntu7.5) but 0.39-2ubuntu2~ubuntu14.04.1 is installed. The following actions will resolve these dependencies: Keep the following packages at their current version: 1) libcgmanager0:i386 [Not Installed]
2) libgl1-mesa-glx:i386 [Not Installed]
3) libglu1-mesa:i386 [Not Installed]
4) libgphoto2-6:i386 [Not Installed]
5) libgphoto2-port10:i386 [Not Installed]
6) liblcms2-2:i386 [Not Installed]
7) libsane:i386 [Not Installed]
8) libudev1:i386 [Not Installed]
9) libusb-1.0-0:i386 [Not Installed]
10) wine [Not Installed]
11) wine1.6 [Not Installed]
12) wine1.6-amd64 [Not Installed]
13) wine1.6-i386:i386 [Not Installed]
Leave the following dependencies unresolved:
14) winetricks recommends wine

Accept this solution? [Y/n/q/?] y

No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used.

  • which broken dependencies do you get. Make your question more informative – akabhirav Mar 24 '16 at 10:42
  • Added som info... – Cai Mar 24 '16 at 10:52
  • you can use aptitude to install it. It'll give you some options to resolve dependencies(Caution:Some of the alternatives may include removing or downgrading some packages that you already have). You can reject an alternative by pressing n or if you find any alternatives that you like, you can accept it by pressing Y. – akabhirav Mar 24 '16 at 10:56
  • use sudo aptitude install wine – akabhirav Mar 24 '16 at 10:58
  • Just so you know, sudo apt-get update && upgrade & dist-upgrade doesn't work like you think it does. It runs apt-get, then it runs upgrade, which isn't a real program. – Olathe Mar 25 '16 at 4:31
0

It seems you have to add support to i386 architecture, to get it working.

Try running:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install wine
  • Unfortunately no difference after this. – Cai Mar 25 '16 at 4:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.